
The following is a list of all changes made to ArchiOffice 2010 since launch on June 30, 2010

v153
1. Fixed an issue related custom invoice template.

V152
1. - Fixed an issue related to syncing of contact on MAC OS.

v151
1. - Fixed an issue with the drag and drop emails in Outlook ArchiOffice Project email folders.
2. - Fixed some issues pertaining to refunds; project balance on invoice was not calculating properly when a refund 

was involved.

v150
1. Fixed an issue with the wrapping of the Project Name on the Billing: Billing Summary report.
2. Fixed an issue with the warning message for invalid Project, RFP and Invoice numbering sequences entered in 

Preferences; now the characters of ' and " are included in the warning message.
3. Performance tuned the Time List View for use with large record sets (400,000+).
4. Fixed an issue with the calendar detail view, when no events were present in the database.
5. Changes to QBooks sync.

v149
1. Fixed an issue with the download and installation of the Outlook sync engine, if the most current version is not 

detected on the clients machine.
2. Fixed an issue with the wrapping of the Project Name on the Project: Billing Summary report.
3. Fixed an issue with the wrapping of the Project Name on the Billing: Billing Summary report.
4. Fixed an issue in Preferences: Project: Defaults; if an invalid project numbering sequence is entered, the dialog 

now shows that the " character is also illegal.
5. Fixed an issue with the Submittal detail dialog, number of copies is now verified to be a number.
6. Changes to QBooks sync.

v148
1. Fixed issue with Euro currency format Word invoicing macro templates, to support the new fields added to the 

General.mer file.
2. Fixed an issue with re-loading of the Preferences: Document: Templates; items should be loaded correctly.
3. Automatic installation of the new Word invoicing macro templates, appropriate for the correct currency version.

v147
1. Fixed an issue with invoice numbering; now existing numbers are skipped and new numbers increment correctly.
2. Fixed an issue with using a single number for invoice numbering (like "100"); increments correctly now.
3. Fixed an issue with re-loading of the Preferences: Document: Templates; invoice type A and B are now loaded 

correctly.
4. QuickBooks sync changes.

v146 
1. Fixed issue with the New Documents: QuickDocs tab; now if you have a template on the QuickDocs tab, or any of 

the filtered views, and the template selected uses sequence numbers, the sequence number field is shown.
2. Fixed issue with Checklist items; now when a ToDo is created from a Project Checklist item, it no longer has the 

Project Number and Name in the event description. For a ToDo to appear on the Home screen, it needs to be 
scheduled with a valid date (budget start date used by default for the new ToDo when created).

3. Fixed issue with invoice numbers; now the system checks to see if the invoice number has been previously used, 
and continues to increment until if finds the next number that has not yet been used.

4. Fixed issue with slip totals; now when you change the job code for a slip, the total and total with tax is 
recalculated (assuming that the job code has a rate assigned to it).

ArchiOffice 2010: Change Log!

BQE Software Inc. ! ArchiOffice 2010 Change Log! Page 1 of 32



5. Fixed issue with the TimeCard report; now the user shown in the TimeCard layout is used for the report.
6. Added ability to Project: Documents tree; now if a subfolder from preferences is missing, you can add that, or you 

can add a parent and all its children. Again, only those set to "Add to new projects" in Preferences are used.
7. Added additional fields to the General.mer export field used for Word invoicing, that will allow users to build their 

own address field configuration on their Word templates. Each part of the address is now exported as a separate 
field (BillSal,BillFirst,BillLast,BillCompany,BillAdd1,BillAdd2,BillCity,BillState,BillZip,BillCountry).

v145
1. Fixed issues on the Project: Budget vs Actual report; now 0% appears instead of null.
2. Fixed issues on the Project: Budget vs Invoiced report; now 0% appears instead of null.
3. Fixed issues on the Project: Submittal List report; was not grouping by Project correctly.
4. Fixed issues with the Payroll report; Sunday in AO now in same week as Mon-Sat, as well as Detail Summary 

hours now correct.
5. Fixed issues with Project: General: QuickView; additional services hours should now be calculated and displayed 

correctly (or at least as close to the real number as HTML % can provide; not exact).
6. Fixed an issue when attempting to link a PDF to a submittal document; should now avoid any errors.
7. Fixed an issue with the Refund notice in the transaction detail view; no longer appears three times if you attempt 

to create a refund.
8. QuickBooks sync changes.

v142 - v144
1. Fixed issues with the Payroll report; should now be working correctly.
2. Fixed issues with the AR report; now should be rounding correctly.
3. Fixed issue with approved slips; must be unapproved first before they can be changed.
4. Fixed an issue with Time List View; was not refreshing calcs at bottom of screen when FIND ALL was run.
5. Fixed an issue with Retainer transactions; now if you pull retainer funds from the account and apply it against a 

project, you can refund the client the money.

v141
1. Fixed issues with Report: Project Budget Hours; changed description.
2. Fixed issues with Report: Project Budget vs Actual; reloaded SQL so 0% shows for % invoiced instead of null.
3. Fixed issue with Report: Project and RFP Checklists; changed description of the report.
4. Fixed issue with Report: Project Profitability Accrued; changed report to show 0% instead of null for totals.
5. Fixed issue with Report: Project Billing Summary; project name when long was not wrapping properly on the line.
6. Fixed issue with Report: Project Slip; sometimes dates were out of order.
7. Fixed issue with Report: Project Submittal List; sometimes dates were out of order.
8. Fixed issue with Report: Billing Summary; project name when long was not wrapping properly on the line.
9. Fixed issue with Project: General: QuickView; the cost of the parent phase was not adding up the cost of the child 

phases.
10. Fixed issue with document sequence numbers; now new docs which use sequence numbers work correctly.
11. Added SubTotal to invoice type A and B when taxes are shown.
12. Fixed an issue where invoice aging calculation was not firing; now it reruns this one calculation on outstanding 

invoices every time you login.

v140
1. Fixed an issue with the Project Slip report not sorting properly; this now groups by Project, then Employee.
2. Fixed an issue with Project Name and Number restrictions; now prevents the use of ".
3. Fixed an issue with the selected Report output format; now if no report format is selected, the VIEW format is 

used by default.
4. Fixed an issue with the Document reports, including the List and all Thumbnail reports. Was not showing all 

thumbnails in the report.
5. Fixed an issue with the Employee Phonebook report; the first phone number on the list is now used, not the first 

created.
6. Fixed an issue with the Contact My List small and large reports; was not showing all the address details for the 

tabs.
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7. Fixed an issue with the Slip reports (including the ExpenseCard report). Was not sorting the records by service 
type. 

v139
1. Fixed issue with Billing: Project Generate Invoice; now if no cutoff or invoice date has been entered, a dialog 

informs the user that batch invoicing cannot proceed.
2. Fixed an issue with the Accounting Export; now only finalized invoices are included in the export file.
3. Fixed an issue with the Accounting Export; now reimbursable expenses that are set to "no charge" will be $0.
4. Fixed an issue with the Accounting Export; adjustments should now be exported in the file.
5. Project Number and Names are checked for illegal characters \/<>*?| or ending with space or period. This 

includes project name change on Project: Detail, project and rfp numbering in Preferences, and post BillQuick 
conversion (the source of the problem detected).

6. Fixed an issue with rounding of expense markup on invoices.
7. Fixed an issue with Print button reports not initializing the Jasper server properly on certain installations.
8. Fixed issues with the Project: Slips view's filters for Approved and UnApproved slips; now working correctly.
9. Fixed an issue with the Invoice creation check for unapproved, incomplete or hold slips; now checks for slips in 

the date range used by the invoice only.
10. Fixed an issue with the Appointments/Milestones portal on the Home screen; double-clicking now takes you to the 

selected record in detail view.
11. Fixed an issue with the Todo portal on the Home screen; double-clicking now takes you to the selected record in 

detail view.
12. Implemented a new feature on the TimeCard and ExpenseCard views; now when you click on a slip in the bottom 

portal, the same slip (and foundset) will be available if you go to the Detail view.
13. Implemented a new feature on the Time Detail View; now when the Approved checkbox is clicked, the details are 

shown like "Approved by HR on 3/3/2011".
14. Quickbooks sync fixes.

v138
1. Reports generated by the Print button (like Summary, Timecard, etc) are now generated in the "[scratch folder]/

reports" directory, rather than in the OS temp folder. Some users were having privilege issues to r/w to their temp 
folder.

2. Fixed an issue with adjustments when applied to time slips; values for an invoice in Project: Billing: Invoices were 
not adding up to the invoice total.

3. Fixed an issue with the Detail Bill report; long invoice numbers were not wrapping properly on the report.
4. Fixed an issue with rounding efficiency calculations on the TimeCard report printed with the PRINT button.

v137
1. Modified the Billing: Project layout by moving the date fields used for invoicing to the bottom of the layout.
2. Modified the Time: Detail view's timer ON / OFF buttons; only one button. Also a clear start and stop time button 

has been added.
3. Fixed an issue with the NEW Time button in the main navigation; now takes you to the new slip.
4. Fixed an issue with the Event Detail Outlook Sync checkbox; when TODO items were created for a task, and then 

the TODO was flagged for sync, it was saying no attendees were assigned. 
5. Fixed an issue with slips that had been previously billed, for inactive projects; project name was not showing on 

the slip.
6. Fixed an issue with slips that had been previously billed, employee names were not showing up if the employee 

was not active (like terminated, on leave, etc).
7. Fixed an issue with the Project: Billings view; now only projects with unbilled slips, that need approval, will appear. 

Issue was that if the "requires approval" flag was turned on in the project, after slips had been billed (and never 
approved), the project would be listed when it had no new slips to be billed.

v136
1. Fixed and issue where the time_amount field was not being set in the invoice table (for QB sync).
2. Fixed an issue with the QBooks export; the Company Name field is now the billing contact's company name.
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3. Fixed an issue with Invoice numbering; numbering was not incrementing properly if the sequence in preferences 
was set to something like "11-0277".

4. Fixed an issue when changing the billing client for a project, the billing flag in the contact list view or detail view 
was not being updated until restart.

5. Changed what documents were showing for Contact: Documents; used to be showing all documents for the 
contacts projects, as well as those assigned to the contact, but now will only show the documents assigned to the 
contact. 

6. Fixed an issue with the Payroll report; detail view should now be showing the Internal hours.
7. New version 5 of beans and plugins; fixes issue in restoring a users sort order on Invoice and Transaction list 

views.

v135 
1. Reruns invoice calculations after v134 data manipulations.

v134
1. Fixed an issue with Project Document syncing, that should prevent folder duplication previously created in certain 

situations.
2. Fixed an issue with Preferences: Users: Defaults assign User button; now properly sets the user_id field of the 

contact the user is assigned to.
3. Fixed an issue with adjustments to invoices, was incorrectly displaying the adjustment amount in the Project: 

Billing: Invoices layout when the adjustment was applied to Time on an hourly invoice.
4. Fixed an issue with the <company name> not being exported in the QBooks file; tag substitution was looking for 

<company_name>.
5. Fixed an issue with invoice adjustments not displaying that was noticed with some customer files.

v133
1. Fixed an issue in the data conversion process; new problem with incoming data identified in a client files.
2. Added the ability to added missing Document template folders to a Project that are in Preferences (only those 

folders set to "add to new projects" are added).
3. Fixed an issue with the Reports module, when using large foundsets; searching from the module (like Time) to 

locate a large set of records, and running a report, did not agree with using the same search from the reports 
module and running the same report.

4. Fixed an issue with Word invoicing; missing descriptions in slips was still causing an error.
5. Fixed an issue with Word invoicing; adjustments were not be displayed properly when applied to Time Total.
6. Fixed an issue with adjustments applied to Time (was not displaying properly in the UI after generation of the 

invoice).
7. Fixed an issue with the Project: Documents BROWSE button; now when you highlight a file, and click the Browse 

button at the bottom right, it opens the folder where the file is, not the file itself.
8. Fixed some issues for the Show Map and Show Driving direction functions both for Contacts and for Projects.
9. Fixed issue for Mac users when they drag and drop a folder (or files) onto the Project Documents table; files/

folders should now be moved to the file server.
10. Added a maintenance button / dialog to Project: Billing that allows the user (with privileges to access billing 

options) to rerun some calcs and fix invoice/transaction issues.

v132
1. Fixed an issue when applying a payment to a project with unpaid invoices; now only invoices with a remaining 

balance that have not been marked as fully paid will have the payment $ applied against them.
2. Fixed an issue with issuing a refund to a client; now checks to see if there are any unpaid invoices but includes 

only those not marked as fully paid.
3. Fixed an issue with Word invoicing; the employee initials for the slips was not being exported properly.
4. Fixed an issue in the TimeCard and ExpenseCard views; if you select and update a slip changing it to a new date 

not in the current week, the portal below is refreshed after the update, so the slip does not appear there if it is no 
longer in the current week.
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v131
1. Fixed an issue with Project Checklist tasks not being loaded in the same order as defined in Preferences (for 

existing projects).
2. OutlookOps.INI file is now updated with the user's Outlook Path every time the OutlookOps.EXE is called. This 

should allow for multiple user profiles on a single workstation.
3. Fixed some issues with the Reports: Billing: Payments report.
4. Fixed some issues with the Project calcs total paid, total invoiced, project balance. There was a rounding error in 

certain situations that has been rectified.

v130
1. Fixed an issue in the expense card view; the top grid was not adding up all the expenses entered for the day.
2. Fixed an issue with receipts attached to billed expense slips; now they are still accessible, provided you have the 

privilege to work with another users slips.
3. Enhanced the slips detail view for billed slips; now the labels are not grayed out. Turns out the field contents need 

to be locked (grayed out).
4. New version of table bean plugins solves some display issues noticed with tables like Invoice List View and 

Transaction List View.
5. Fixed some issues with the Reports: Billing: Billing Summary report.
6. Fixed some issues with the Reports: Billing: Billing Detail report.

v129
1. Fixed some issues with the Project: Slips view; now Actual, Remaining Hours and Amounts, should be computed 

for the Basic Service time only.
2. Fixed an issue with some Project Phases not holding their sort order after modifying in Project:Details:Phase and 

moving to Project:Billing:Summary.
3. Made some changes to how the Project Hourly cap is applied; was not working in all cases.
4. Made some more changes to the Invoice Type A and B templates to allow for the Stipulated Sum + Add srvcs, as 

well as invoices with only Hourly, to print properly.
5. Fixed an issue with the new TimeCard Report (print button on TimeCard layout) to fix an issue with the Efficiency 

for Monday calculation.
6. Made a change to the Preferences: User: Sync layout, so that on a Mac, the default scratch folder is "" rather than 

"c:/ArchiOffice_sync".
7. Fixed an issue with the Events and ToDo items report; was throwing a Java error in certain situations.
8. Fixed an issue with the Slip Cost report; was not displaying the correct cost field (cost rate X qty_hrs).
9. Fixed an issue with the Contact: Documents portal; when navigating to Project:Documents, then back, and 

attaching a file, then trying to launch the file, the wrong record was being used.
10. Fixed an issue with the Project: General: QuickView's Cost rate; was not using cost_rate x qty for expenses.
11. Fixed an issue with the Report: Billing: Detail Bill Report; Adjustments were not displaying correctly.
12. Fixed an issue when creating an invoice, and an overpayment exists on the project that pays it off in full, that the 

fully paid flag is set on the new invoice.
13. Fixed an issue with the Preferences: Users: QuickView; calcs were not working if Sat and Sun required hours for 

an employee were null rather than "0".
14. Fixed an issue with the Project: Contacts Directory report; now only active Employees show on the report.
15. Released a new report for support that allows problem projects to be detected, where the next invoice will have 

the incorrect account balance information.
16. Implemented a method to detect problem projects with respect to account balances for the next invoice to be 

created, and automatically repair the problems.
17. Fixed an issue where users were able to leave an incomplete transaction record in the system; started a 

transaction but then closed the window with the X in the top right. 
18. Update will automatically remove any incomplete transactions (no transaction items).
19. Update will automatically repair the transaction total amount and amount remaining if problems are detected in 

the transaction.
20. Update will automatically repair any invoice paid/remaining issues that are detected.
21. Fixed issues related to the Report: Project: Billing Summary; now adjustments are included in the calculations.
22. Fixed issues related to the Report: Billing: Billing Summary; now adjustments are included in the calculations.
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23. Fixed an issue with Invoice Tax (was not rounding correctly and sometimes 1 cent short).
24. Fixed an issue with Credits on a Project not being properly applied to new Invoice.
25. Fixed an issue with Payments from Retainer not being properly applied to a new Invoice.
26. Fixed some issues with the invoice templates; were not showing refunds on the invoice correctly.
27. Fixed some issues pertaining to refunds; project balance on invoice was not calculating properly when a refund 

was involved.

v128 
1. Made some changes to the "Slip Report with Cost"; sort for"by Week" was not working, summary of expenses 

was a separate line when report was by day, week or month, expense types were on a separate line when report 
was by day, week or month.

2. Made some changes to the "Slip Report"; sort for"by Week" was not working, summary of expenses was a 
separate line when report was by day, week or month, expense types were on a separate line when report was by 
day, week or month.

3. Made some changes to the "Slip Report with Notes"; sort for"by Week" was not working, summary of expenses 
was a separate line when report was by day, week or month, expense types were on a separate line when report 
was by day, week or month.

4. Made some changes to the "Time Card Profitability Report"; sort for"by Week" was not working, summary of 
expenses was a separate line when report was by day, week or month, expense types were on a separate line 
when report was by day, week or month.

5. Made some changes to the "Time Card Report"; sort for"by Week" was not working, summary of expenses was a 
separate line when report was by day, week or month, expense types were on a separate line when report was by 
day, week or month.

6. Made some changes to the "Periodic Totals"; sort for"by Week" was not working, summary of expenses was a 
separate line when report was by day, week or month, expense types were on a separate line when report was by 
day, week or month.

7. Made some changes to the "Expense Card Report"; sort for"by Week" was not working, summary of expenses 
was a separate line when report was by day, week or month, expense types were on a separate line when report 
was by day, week or month.

8. Made some changes to the "Project Slip Report"; sort for"by Week" was not working, summary of expenses was a 
separate line when report was by day, week or month, expense types were on a separate line when report was by 
day, week or month.

9. Made some changes to the "Profitability Accrued" report; non reimbursable expenses were being included twice in 
the profit calculation.

10. Added a new Project Transactions report (PDF only) to the PRINT icon on the status bar (lower left) for the 
Project: Billing: Transactions layout.

11. Added a new Project Invoices report (PDF only) to the PRINT icon on the status bar (lower left) for the Project: 
Billing: Invoices layout.

12. Added a new Project Notes report (PDF only) to the PRINT icon on the status bar (lower left) for the Project: Logs: 
Notes layout.

13. Added a new Project Budget report (PDF only) to the PRINT icon on the status bar (lower left) for the Project: 
Billing: Budgets layout.

14. Added a new TimeCard report (PDF only) to the PRINT icon on the status bar (lower left) for the Time: Timecard 
layout.

15. Modified the Billing: Billing Statement report; now when producing the report with a foundset of projects, each 
project statement is on a separate page.

16. Made changes to all the Contact: Label reports, so that the address is displayed better, even if data is missing 
(like no sal, address2, etc.).

17. Made changes to the Contact: AddressBook Large and Small reports, so that the address is displayed better, 
even if data is missing (like no sal, address2, etc.).

18. Updated some display issues for the Profitability reports; simpler description, correct spelling for Project Type 
parameter.

19. Fixed the sql for the Profitability Cash report; sometimes would not show budget $ or actual $ on the report.
20. Implemented a major new way of checking over the Internet for new versions of the OutlookOps and Applescript 

software, and downloading and installing it as necessary on client machines. This needs to be tested with both 
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date formats of clients (Int and US).Test to ensure it inserts version 2.1.10 of the applescripts into the user's 
scratch folder; this will be downloaded from the Internet and will not use the "reports" folder anymore.

21. Removed EXCEL and XML report output format; since these two output formats only work intermittently, 
depending on the OS, Excel version installed, and report being outputted. This is controlled by the JasperServer, 
which renders the output, and nothing we have control over. We have disabled these two output formats to avoid 
further complaints. 

22. Fixed an issue with the Time List View Update menu: Update Project; was hanging in some cases.
23. Added some code to check for important system Document Types, including "Folder", "Email", "Acrobat" or "PDF", 

and "Image". These document types have special meanings in the system, so as creating thumbnails, launching 
particular detail views, etc., and will therefore be added if missing (but no thumbnail will be included if added). 
Also, these types cannot be deleted or renamed moving forward and are fixed.

24. Changes to Applescripts; Sync Manager 2.1.10 now being used which solves some problems with contacts being 
added to the "ArchiOffice" group in AddressBook.

25. Fixed some issues with Adjustments on invoices; now applies adjustments against time and expenses properly 
again.

26. Fixed an issue with Word Invoicing; if the scratch folder does not exist, it is created.
27. Fixed an issue with a username valuelist refreshing when a new user account is added; now newly added user 

accounts are available on the Project: FIND screen.
28. Fixed an issue with the Assigned Contacts filter on Project: Events view; now does not include users, only 

contacts.
29. Fixed an issue with the Billing Status flag refresh (Red/Green checkbox in List View and Contact Detail View) after 

a transactions is created/or deleted from the Contact: Transactions view.
30. Fixed an issue with the Project: Budget view; now when turning hourly on / off for a phase, the budget values are 

moved appropriately for parents without children, as well as children and parents.
31. Fixed an issue where backup jobs were not automatically starting again after an update is applied. This is 

because we are swapping out the servoy_repository.db when we do an update in the field. Now, when the update 
completes, it will attempt to fire the configured backup job. If no job is setup, the user will be notified that this is a 
problem and where to go to setup a backup job. If for any reason the automatic firing of a configured backup job 
fails, the user will be notified and asked to manually fire the backup job.

32. Fixed an issue with the Project: Summary view; amount invoiced hourly was not being calculated correctly.
33. Fixed an issue with the Project: Options view; percent invoiced was not being calculated properly (was including 

hourly phase).
34. Fixed a bug with the export for Word invoicing; was always showing two taxes, even if just one tax rate model was 

being used.
35. Prepared a Euro currency version of the Word Invoice_b&W template.
36. Fixed an issue with Invoice Type A and Type B; was not capable of showing more than 15 phases on a stipulated 

sum invoice.
37. Fixed an issue with the Time List View Update menu item "Emp Not Paid Out" option.
38. Fixed an issue with the Time List View Update menu item "Reimbursable" option.
39. Fixed an issue with the Time List View Update menu item "NonReimbursable" option.
40. Changed the Responsible field for a single user assigned to a Checklist Task to only show the initials of the user, 

rather than their name.
41. Fixed an issue with Project Document syncing; calcs like project name, contact name, were not refreshing. NOw 

they will after a sync, and the update also forces all doc calcs to refresh to correct the problem.
42. Fixed an issue with conversions; now after conversion, the display phase name and job code name are refreshed 

(used on reports). Also running the refresh of these calcs in this update.
43. Fixed some issue causing Java bean errors in table views when sort was applied to specific column. Turns out the 

bean cannot sort the column if there is a null value, so 0 is now displayed in places where before null was. This 
should avoid the Java bean null pointer exception on those views.

44. Fixed an issue with Applescript sync; attendees added to an event in iCal, where not appearing in the event in AO  
after sync.

45. Fixed an issue with the Contact: Project filters; was not showing the correct filter options when navigating from 
one contact to another.

46. Fixed an issue with the New Document Wizard dialog (used to create a new doc from Contacts or Projects); 
Project value list was not being populated properly.
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47. Fixed an issue with the Project:Billing:Invoices layout; the adjustments column was not displaying the correct 
information.

48. Fixed an issue for the Time portal on the HOME screen layouts; now when the new Slip icon is clicked, an new 
slip is created for the logged in user and the slip is displayed.

49. Fixed issues with Credits being applied against a project; amount, remaining amounts were not correct after the 
credit had been applied, and the dialog to select which credit to apply the amount against did not have a valid 
message and could not be cancelled from. You still have to specify a credit account to use, so we trap for that 
before trying to leave the record.

50. Fixed a spelling mistake in the Transactions dialog that tells the user they have extra funds left over.
51. Fixed an issue with Hourly Phase caps; caps were not being applied properly.
52. Fixed an issue on the Project: Billing: Options view for Stipulated Sum projects; when billing by Fees, entering a 0 

or null for a phase was not clearing out the % Complete calc.
53. Fixed an issue with the Project:Details:Phase layout; when changing the Active checkbox (or any of the others), 

the current phase stays selected.
54. Fixed some issues on the Project:General:Data layout; you can now edit Publications and Awards as well as 

some general UI cleanup.
55. Fixed an issue with the Project: Documents attach new File and the Select Project Folder tree; now eliminates 

any possible duplicates created from other user sessions.
56. Added a small label to the bottom right corner of the Preferences area, that will display the Servoy Repository 

code version. This should let support identify whether or not the client is running the correct version. This should 
be the same as the version the clients AO database is updated to, but has been different in some cases in the 
past.

57. Fixed an issue with the Project: Slips view; the ACTUAL hours now displayed for the phase in the top right table, 
now only shows hours for Basic Services and does not include Additional Services.

58. Fixed an issue with the user's Active flag not refreshing when they logged in and immediately went to the Contact 
List View.

59. Fixed an issue with Contact deletion; could not delete the current contact in the detail view.
60. Fixed an issue with the Preference: Billing: Accounting Company Name format option; was not working properly.

v127
1. Added a new filter to new Document creation All Docs tree. Nw only those user folders in Preferences set to "Add 

to Projects" appear, along with Labels, Envelopes and General. This is so users that have customized the 
document template folders in preferences, but not delete our original templates. Users can simply hide the 
originals they do not want users to access.

2. Fixed an issue with some project total calculations; now total invoiced, total paid and balance are rounded to 2 
decimal places.

3. Fixed an issue with the Billing: Projects Client filter; now, even if the client has no invoices, they will show up when 
the filter for their name is used.

4. Changes to QuickBooks sync; now firms using a Mac server for ArchiOffice  can use QuickBooks on a PC and 
sync with ArchiOffice on the Mac Server.

v126
1. Fixed an issue with Project: Billing: Options invoicing table; when changing a $ or % value for current invoice 

amount, and clicking somewhere else on the screen (rather than in the next field), the total at the bottom was not 
correct because the change was not being saved to the data table. 

2. Fixed an issue when no Invoice template is selected for the project, the invoice throws an appropriate error dialog 
letting the user know this is the missing item needed before an invoice can be created.

3. Fixed an issue in the Project: Billing: Invoices view; now when opening the the detail view for an invoice, and then 
closing it, the navigation on the project status bar is updated.

4. Fixed an issue with the Contact Name dialog; no error if middle initial is missing.
5. Refreshing the project team member calcs on the update.

v125
1. Fixed an issue with the Contact detail name link; now the form opens to always show the first/last name for the 

contact record you are on.
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2. Fixed an issue with Pref: Doc: Templates; now when you add a parent node in Preferences, and go to add a new 
doc in Project: Documents: New: All docs, you will see the new node.

3. Fixed an issue with the MYOB export; on the Mac the .tab file extension was causing problems. Will now be a tab 
delimited file with the .txt file extension.

4. Fixed an issue with Preferences: Accounting: Expense Codes; now when an Admin user attempts to delete and 
expense code, they are warned if it is in use.

5. Fixed an issue with the Project: Slips view; now when an Expense code has been deleted in Preferences, and 
Expenses are viewed on a project that used that deleted code, "" is displayed for the code rather than throwing an 
SQL error.

6. Fixed an issue with the Project: Billing: Invoices view; when sorted by the fully paid checkbox, and there were 
both fully paid and not fully paid invoices, a bean error was being thrown.

7. Fixed an issue with the Billing: Outstanding view; when sorted by Aging column, bean error was being produced 
when the user returned to the view later.

v124
1. Removed an infinity character that was showing up in the Project: Billing: Summary view, when there was no 

budget specified for a phase.
2. Fixed an issue with the Project: Billing: Options layout, where when an invoice was finalized or deleted, the % 

current invoice for a parent phase was not being cleared out.
3. Fixed an issue with the Menu: Record: Delete Record; now when in the projects module, and you use this menu 

item, a better message is displayed like "Are you sure you want to delete this Project record", rather then omitting 
the "Project" and not being clear (user may think they can delete a Submittal in the Project Logs, for example)

4. Changed Contact Detail View; added a hyperlink to NAME for the Contact (on far left), which will open a dialog 
allowing the user to change the autoparsed first, middle and last names.

5. Fixed an issue with the Menu: Record: Omit record; now, when in a detail view, like Project: Billing: Options, and 
you use the omit menu function, it omits the correct record, moves you to the prior one, and updates the 
navigation on the status bar.

6. Fixed an issue with the Transaction: List View; deleting a record with the Menu: Records: Delete function, now 
deletes the selected record, leaves the remaining records in the list view, and set the navigation in the status bar 
to the correct Record X of Y count.

7. Fixed an issue with Contact: Documents; now when deleting a document (with trash can), the portal is refreshed.
8. Fixed an issue with Transaction Detail View; now when updating the transaction date, the date for the individual 

transaction items are updated to the same date.
9. Fixed an issue with Project: Detail; Departments value list is now the same order as in Preferences.
10. Fixed an issue in Preferences with auto Project Document naming; now Document Date and Document Create 

Date have been removed from the naming options ("/" interfere with paths).
11. Fixed an issue with the Invoice List View; added new hyperlinks to access related data (like contact, project, etc.)
12. Fixed an issue with the Import data method; Contact type, State, Country and Sal now imported correctly.
13. Fixed an issue with the Import of Contact and Time records; calcs were not firing. Now, in the Contact List View, 

you should see the phone number formatted properly. After importing time records, the calcs (like in Project: Slips 
view) should accurately reflect the new hours/$ for a phase or employee.

14. Fixed an issue with Contact searches for sync flag; additional code changes should find all contacts flagged for 
user sync.

v123 
15. Applescript sync; now when the user changes a phone label in AddressBook, the field will not sync (as before), 

but also it will not clear out the ArchiOffice data. The changed field is simply ignored.
16. Extensive changes to the QuickBooks sync.
17. Fixed an issue with Word invoicing; error in the MER file caused by double-quotes used in the description of slips 

(was breaking the field delimiter for Word). Now double-quotes are converted to a single quote for all slip 
descriptions sent to a Word invoice.

v122
1. Fixed an issue with Word invoicing; if user did not have some fields set for fixed fee services to be build, an error 

was occurring. Now using 0 instead of null.
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2. Fixed an issue with adding an Invoice template file; now if you cancel the select file dialog, no error is thrown.
3. Fixed an issue with Expense cost rate; now if you have a cost rate, and change the bill rate, the cost does not 

change (only changes if 0 or null). Also, if you change the expense type, the cost rate is set to the new bill rate for 
that new expense type.

4. Fixed an issue with refreshing of the cost rate on the Time Slip detail view; now when changing things like 
employee, project, slip type, the cost rate is refreshed.

5. Fixed several issues with the Report: Slip with Cost and TimeCard Profitability reports; for expenses, now using 
the cost rate from the expenses.

v121
1. Fixed an issue with the Invoice List View; omit down now works without error.
2. Fixed an issue with the Billing: Projects Yellow Draft flag; now when deleting the draft invoice in the Billing: Drafts 

view, then returning to the Billing: Projects view, the Yellow Draft flag should be cleared.
3. Fixed an issue with Expense default Cost Rate; now defaults to the Bill Rate, not Qty * Bill Rate.
4. Fixed an issue with the Project: Billing: Transactions view; clicking the NEW button to create a new transaction 

was showing a previously searched for record, and not a new blank one.
5. Fixed an issue with User security privilege Time: View Rates; now removes the $ column from the lower table in 

the Project: Slips view.
6. When the user logs in (even on re-login) and types in an incorrect password, a dialog is shown advising them of 

the incorrect username/password, and then they are return to the username field to try again. Before no dialog 
was shown.

7. Fixed an issue on the Time Slips Detail view; when the Employee is changed, the Task field is also now cleared.
8. Fixed an issue in Preferences: Projects: Tasks view; now if no Task Type is selected (blank) and the user clicks on 

the delete button, no SQL error is displayed.
9. Worked through several Applescript bugs.

v120
1. Fixed an issue with the delete button in the Email Info dialog; now closes the form when you click delete.
2. Fixed an issue with the UPDATE/ADD Records menu in Time and Expense card views; UPDATE does not add a 

blank record.
3. Removed QuickBooks Menu item for Send Expense Entries to QuickBooks.
4. Added clc_outstanding column to database tables so this calc is stored and can be used in the Invoice FIND 

screen; find outstanding invoices only.

v119
1. Fixed a refresh issue with Project: Detail: Phases and Project: Detail: Job Codes, when moving from project to 

project. Phases and Job Codes in the tree should now display correctly.
2. Changed Job Codes, so they can also be dragged and dropped and their Parent Job Code can be cleared (child 

can be made into a parent) like Phases.
3. Fixed an issue with Project: Detail: Job Codes; now when changing the selected job code name, it remains on the 

selected job code record.
4. Fixed an issue with the TimeCard and ExpenseCard Records menu options: Add Slip and Update Slip.
5. Fixed an issue with the Email Info view; when clicking on the Delete button, the email should now be deleted and 

the Email info form should close.
6. Changed the Document List View by adding a delete button.
7. Fixed an issue with Draft creation; now if no invoice template is specified in Project: Billing: Options, then the user 

is notified and the invoice process is aborted.
8. Fixed an issue on the Invoice FIND screen; Project Number field now displays the Project Number valuelist.
9. Fixed an issue on the Invoice FIND screen; now if you select the outstanding checkbox, only invoices that have 

not been paid in full will be included in the search results.
10. Fixed an issue with the Attach File button on Preferences: Documents: Templates; when the template you were 

trying to attach was already in the template directory, an error was being displayed (file could not be copied to 
destination).

11. Fixed an issue with the calculation used for Phase name display, that builds Parent: Child structure. Affects 
certain clients when running update 109.

!

BQE Software Inc. ! ArchiOffice 2010 Change Log! Page 10 of 32



12. Fixed an issue with the Applescript Sync Installer. It was only attempting the install one time in a client session, 
then assumed it was installed. Now checks every time and will install if found missing.

v118
1. Fixed issue with Mac Applescript installer; should now be installing the applescripts into your scratch folder 

correctly.
2. Fixed an issue with a document path calculation that was preventing new project document folders from being 

created correctly on the file server.
3. Fixed an issue with the Billing: Projects view; when deleting a draft (like in the Billing: Drafts view), the yellow draft 

flag was not being refreshed in Billing:Projects. Calc is now firing on invoice deletion.
4. Fixed an issue with the Billing: Drafts view; now when you click on the total column, you will go to the Time list 

view and see the slips on that draft invoice.
5. Fixed an issue with Expense slips; their cost_rate will default to hours * bill rate, and can be changed just like a 

Time slip cost rate (if you have privileges to do so).
6. Fixed an issue with the Draft invoice process; the flag responsible for indicating the project has a draft in the 

Billing: Projects view was not getting set when the draft was being calc. Now both on creation of a draft, deletion 
of the draft, or finalizing the invoice, the calc is rerun and the project draft flag is updated.

7. Fixed an issue with the Profitability Chart; now showing all cost (time & expense), not just slips that were invoiced, 
and the cost is shown for the month the slip was entered for.

8. Fixed an issue when using UNBILL menu option on the time Slip Detail view; now after unbilling a previously 
invoiced slip, the view will refresh.

v117
1. Modified invoice creation sql to avoid errors when a project has the same team member more than once.
2. Modified Word invoice creation sql to avoid a null exception error.
3. Expense slips now created from the Project: Slips view will be created with flag_markup set, and charge status 

set.
4. Some additional debugging with Applescript syncing. Now working properly for both Entourage, AddressBook, 

iCal and Mail. Only bug has to do with Salutation field. AppleScript Development is also working on using the 
Phone/Email names in ArchiOffice for the Phone/Email names in AddressBook.

5. Fixed an issue with the Time List view; now when deleting a Draft invoice, the Time List view will refresh, so that it 
no longer shows the "D" for the slips that were involved in the Draft.

6. Fixed some issues related to the Project Job Code children not displaying correctly for the parents in some views.
7. Fixed some display issues with the Project Invoiced vs Budget and Project Actual vs Budget reports. Still working 

on getting the additional services values into these numbers on the report.
8. Fixed issue with multiple Report nodes in client files; now cleans out any extra nodes.
9. Fixed issue with missing invoice templates; several different types of checks are run and the templates are 

installed if necessary.
10. Fixed issue with missing report assets; if they are found missing, they are automatically installed.
11. Minor fix to invoice templates to accommodate large invoice messages at the end.
12. Fixed an issue with Invoice interest, where interest was showing as a negative in some cases. Interest is now 

computed on overdue invoices, since the last invoice was sent out (if any prior invoices exist). This ensures that 
we are charging only the additional interest that has accumulated since the last invoice.

13. Fixed an issue with the Contact Address Reports; when not using a foundset, the address to use flags are used in 
the sql.

14. Fixed an issue on the Calendar Detail view; when clicking +Slip, the slip is now created using the event date, and 
should ensure the slip is created for the same day as the event (not the next day).

15. Fixed an issue when adding a slip from the Calendar Detail view (using the +slip process); extra "\n" characters 
appearing for some users should now be removed from the slip creation dialog process.

16. Fixed an issue with the Slip Detail portal on the right that shows the slips for the filtered criteria; was not applying 
the users currency format to the listed expenses.

17. Fixed an issue with the Expense slip bill rate on Invoices; now is calculated by (slip amount / quantity), which will 
properly reflect the markup that was applied to the expenses.

18. Fixed an issue in the Contact detail view that was preventing additional address tabs from being created for the 
contact using the + icon.
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19. Fixed an issue with invoicing where the total Cap is reached in the middle of a slip; now the slip is adjusted for just 
the remaining amount from the cap.

20. Fixed an issue with the Invoice vs Budget report; actual hours should now be just the Basic Services and not 
include Additional Services (should agree with Project: Billing: Summary view for Basic Services).

21. Fixed issue with the Contact List reports for Mac; Directory checkbox should now be visible.
22. Fixed issue with the Contact List reports; using the Mailing, Billing or Directory checkboxes now displays the 

correct addresses for the contacts in the reports.

v116
1. Fixed an issue with the accounting export, where special type of credits was not being assigned to an account 

code properly in the export file (was showing up as 'undefined').
2. Fixed an issue with move arrows on tree views that move items up or down; in some customer files this was not 

working.
3. Fixed an issue where in some customer files, active employees where not appearing in the time/exp employee 

valuelist. Now all employees with status "Active" appear in the list.
4. Fixed an issue with the Project: Billing: Invoices view; reimbursables now includes reimbursables + markup in 

column and Expense total.
5. Changed Project: Detail: Phase drag and drop code; now a parent can be made into a child (just drag a parent 

onto another parent), and a child can be made into a parent (using the eraser next to the new Parent Phase field 
in the User Interface).

6. Fixed an issue when searching for a single Date (like 12/9/2010). Was returning all records rather than just the 
records matching the date range specified.

7. Fixed an issue where users with an account code called "Interest Income" were getting <undefined> in their 
QuickBooks export. Label has been changed to "Interest".

8. Fixed issues with Billing: Transactions report. Grand summary shading and fields were not displaying correctly.
9. Fixed an issue with the Transactions Find screen; Project Name and Number had the Number valuelists.
10. Fixed an issue with the Projects: Billing: Transactions view; if you did a search for transactions, then returned to 

the view, then double-clicked to see the detail for a specific transaction in the grid, the wrong transaction was 
being shown.

11. Added the record info footer (Created by, Modified by) to the Time Slip Detail view.
12. Fixed an issue with Retainer Refunds; the retainer refund now shows in the Refund column, and the calculation 

for total paid includes the retainer refund.
13. Fixed an issue with searches; when logging in and immediately searching for contact, project, time or calendar 

records, the user was not being shown the foundset in the list view (but rather their prior records they had in this 
view).

14. Changed the SQL for the Cost series of the Profitability Charts; now Cost is calculated from the slips for that 
month, and not just slips that were invoiced.

15. Fixed some issues with the Time: Payroll report. 
16. Fixed an issue with the hourly Backup job not starting if the subfolders for the days of the week did not exist in the 

primary backup location. Now the subfolders are created automatically in the backup folder.
17. Fixed an issue with the Projects: Invoiced vs Actual report; was not showing the hourly invoiced fees.
18. Fixed an issue with the Time Slip Report with Notes; now this report is only available in Detail. Option to use 

Summary is disabled for this report, since it would make no sense to summarize a report for notes.
19. Fixed an issue with the Projects: Invoiced vs Budget report; was not showing the hourly invoiced fees.
20. Fixed some issues with Reports: Contacts: Labels; address details were not appearing correctly if the contact was 

missing some address data. Keep in mind this shows only the address flagged "mailing" for the contact.
21. Fixed some minor spelling issues on some ArchiOffice Document templates.
22. New time slips created from the Project: Slips view, or from the TimeCard view, are created correctly with the 

"Charge Status" set to "Charge" by default.
23. Payment transactions are now written to the QuickBooks export file with TRNS as the first item, so that they 

export correctly to QuickBooks.
24. Fixed an issue with Omit Down. Was not omitting the correct records when the list view was sorted by some 

column(s).
25. Fixed an issue with the Contact: AddressBook Small report; used address flags Billing/Mailing/Directory were not 

working.
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26. Fixed an issue with the Contact: AddressBook Large report; used address flags Billing/Mailing/Directory were not 
working.Fixed an issue with the Contact: AddressBook Small report; contacts address information was not printing 
if an address field was blank.

27. Fixed an issue with the Contact: AddressBook Large report; contacts address information was not printing if an 
address field was blank.

28. Fixed an issue with the Project: Billing: Options view; changing the Invoice Time or Expense methods (like 
Itemize, Itemize by Employee), was having no affect.

29. Fixed an issue with the Project: Billing view; occasionally the same project would be shown in the view more than 
once.

30. Changed how the row is highlighted to indicate their is a draft; now the checkbox at the end of the row is the only 
thing highlighted and no black border is used. Should be more subtle and hopefully more attractive.

31. Changed the export format for mail merge lists (like phases) to use a carriage return and line feed (\r\n) instead of 
just a carriage return (\r).

32. Fixed an issue with Project Numbering; now when using a number sequence like 2010-01, it increments correctly.
33. Fixed an issue with canceling the dialog to confirm the new Project Number during the new Project creation 

sequence; now canceling the dialog does not use up the next Project Number in the sequence specified in 
Preferences: Projects: Defaults.

34. Changed security for Project: Slips view; now users that cannot see slip values, can get to the view. In the view, 
all $ amount fields are hidden. In the lower table, the $ column is blacked out, as this is the only way I can hide 
the values from the user.

35. Changed security for Project: Billing: Summary view; now users that cannot see slip values, can get to the view. In 
the view, all $ amount fields are hidden. 

36. Fixed an issue where a rogue transaction could prevent an invoice from being deleted. 
37. Changed the Project: Billing: Invoices view; reimb expenses on invoices now include any markups that were 

applied to the expenses.
38. Added new valuelist preference for Departments in Preference: Project: Defaults; now Admin can define a list of 

predefined values for the department field, and this list will be used for typeahead in the Department field on the 
Project: Detail layout. Also used for typeahead in the Department field on the Project Find screen.

39. Changes to an Account name in Preferences is now populated throughout the system.
40. After making a refund, the refund link is no longer visible on the Contact: Transaction layout.
41. Now when a user attempts to login with an incorrect password, even during re-login, an error message will display 

(invalid password).
42. Fixed issue with deleting a submittal; only one confirmation dialog is now shown.
43. Changing the employee name on the Slip Detail view, now clears phase, job code and task.
44. Fixed issue in Projects: Billing: Summary actual section; now clicking on one of the lines for Additional Services at 

the bottom should take you to the correct slips.
45. Fixed issue in Time Expense, Records menu "Delete All" option; only one confirmation message should now 

appear.
46. Fixed issue with Project: Documents; paperclip icon now copies the files path to the clipboard.
47. Fixed issue with notifying the Admin user of updates; now declining notification will be respected.
48. Fixed issue with the Time Expense Detail view; clicking the paper+ icon in the main navigation will create a new 

slip and show it in the detail view.
49. Many fixes for QuickBooks sync.
50. Numerous Applescript syncing bugs were fixed.
51. Fixed an issue with the converter that was deleting all the report assets, preventing any reports from running. 

Clients experiencing this problem with the 114 converter need to re-download the converter install and rerun the 
conversion.

52. Installed a global method to fix all missing report file join records (removed by the converter bug).

v115
1. Turned on QuickBooks sync.

v114
2. Fixed SubTasks in the TimeCard task menu; now children appear for their parent task.
3. Fixed Profitability Accrued report.
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4. Fixed an SQL error when switching to Expenses in the Project Slips view, and you had expense slips that were 
incomplete and had no total $.

5. Radio buttons are now properly aligned for Mac in Charts.
6. Existing Expense slips can now have their date field modified.
7. Clicking the Slip status icon in the Slip detail view now shows the phase and job code fields disabled, so they 

cannot be changed.
8. Issue with Invoice detail screen, where occasionally it displayed "\\Finalized" has been fixed.
9. Fixed an issue with the secure notes field on the Contact FIND layout; will now search secure notes for the partial 

note details you enter on the FIND layout.

v113 
1. Updater is now applying a sort order to the Preferences: Project: Teams, and when viewed, the list is sorted. This 

should avoid any confusion when the team is added to a Project later.
2. Retainer now showing again on invoices when requested.
3. Time slip duplication does not look up the user rate if there was a rate on the original slip.
4. Active users valuelist now no longer shows the employee "<<Deleted>>".
5. Updating an i18n entry to see if it fixes the add slip from event dialog (unusual characters seen by one user).
6. Changed a workflow process; team members can now be deleted from projects regardless of what they did or are 

assigned to, except if they have entered slips (then they cannot be deleted only deactivated).
7. Fixed an issue with the TimeCard task menu not being populated with the Tasks that are unassigned. Now the 

menu shows the user the tasks they are assigned to, as well as any tasks that are not specifically assigned to 
others. The list excludes those tasks marked as "Completed" or "Not Applicable".

v112
1. Team members now get added to a project in the same order as in preferences, and with their roles.

v111 
1. Fixed some tooltips in Preferences: Security
2. Fixed the Project: Checklist report; SQL was hanging.
3. Updated security privilege for Contacts "Lock/Unlock Contacts" to "Lock/Unlock Contacts and view Secure Notes"
4. Fixed a bug in Time Slip detail view which was preventing the interface from fully refreshing.
5. Fixed an issue with the updater script throwing an error if no project member roles were in use.

v110
1. Fixed rollover tooltip for checkbox in Preferences: Workgroups: Security & Reports.
2. Added secure notes to Contact Find layout.
3. Added some code to the updater to repair any Project Team Member roles that are being displayed for example 

as "Principal 125,245", updating the value to "Principal".
4. Changed the Active Users valuelist, so it now only shows employees with the Status = "Active". So now, when 

adding a Team Member to the Preferences: Project Teams, it will only show the active employees. Note: If you 
previously had an employee on a team and now make them “On Leave” or “Terminated”, their name will no longer 
appear but their former ID number will, hence you will need to delete the former team member from the team.

5. Time Expense Find now has a typeahead list for Project Leader names.
6. Project Milestones were not appearing on the calendar, if the date was set manually, rather than using the 

calendar date control. They will now show up in both cases.
7. In unusual circumstances, when attempting to create an invoice, an error was being thrown while checking for 

Word templates.
8. When assigning the Project Team, the order of the Teams is exactly the same as the order in the Preferences.
9. Time Slip Detail View now uses the Project Team Roles value list, which includes all the roles defined in 

Preferences, regardless of what roles are on the selected project.

v108/v109 
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1. Fixed an issue in Preferences: Documents: Templates; tree is now regenerated when a subfolder is added (was 
disappearing)

2. Fixed an issue in Preferences: Documents: Templates; new folders added were showing up with the WORD icon 
on the right (should have no icon)

3. When creating a new project, the calc of the phase and job code names used in reports was not firing.
4. Update will fix any phase and job code names in a calc used on reports.
5. Update will remove any Preference folder that are showing the WORD type icon (should show none).
6. Fixed an issue with Project Team roles value list; was showing the role name and a number, will now only show 

the name. You may need to reset the role to display properly.
7. Fixed issue where a non-licensed user account could still be used to login.
8. Fixed issue with Preference: Project: Teams valuelist for team members; now only active users are showing up.
9. Fixed issue with Time Find screen; project leader search field is now a text search and no longer shows a 

principal valuelist for type ahead.
10. Fixed an issue with Checklist tasks; child sub tasks were not appearing under their parents (sort order not being 

observed).
11. Implemented another check to ensure that when navigating away from Projects (like to Preferences), and then 

return back using the Project tab in the main navigation, you are returned to the same view and project in the 
Projects module.

12. Fixed an issue with the Project: Billing: Options layout; now rather than typing 0 into the % Current Inv field to 
clear it, you can simply use the delete key to clear the field.

13. Made a change to code that checks for updates available (over the Internet), hopefully preventing any problems 
when the client is does not have any Internet access.

14. Fixed an issue in Preferences: Users: HR layout; date fields now are formatted according to the system date 
preference.

15. Investigated an issue regarding tax rate. In Preferences, if you entered a tax rate of 0.12 (displayed as 12% after 
you leave the field), then logged out, and came back, it now says "11.99%". This then introduced errors into 
projects, slips, and finally invoices. So, in the interim, the % display has been removed (same on Project: Billing: 
Options: Tax and Slip Detail Tax). The tax rate will appear as "0.12", just the way the user enters it. Changed the 
label to "Rate/100" instead of "Rate". Will be addressed better with column converters (user will be able to enter a 
% and it will display a %) later in feature requests.

16. Fixed an issue with Preferences: Documents: Templates; now when a new folder is created, with a new template 
file, and a new project is created with this new folder, an new doc for the new project is filed properly in the folder.

17. Fixed an issue with the Project: Detail: Phase layout; changes to the budgeted hours were not firing the calcs, 
which updates the Summary and Budgets view of the project.

18. Fixed an issue with new Project creation; budget calcs were not firing, so totals on Budgets and Summary layout 
were not calculating.

19. Increased the length of the Preference: System: Company email field to 100.
20. Fixed an issue with the Project: Billing: Options layout; collapsing / expanding a parent phase was turning on/off 

the "Show on Invoice" flag.
21. Fixed an issue with the Project: Billing: Options layout; when switching invoice method from Stipulated to 

Percentage of Construction or Unit Cost, the budget total was being cleared. Now retains the budget total 
regardless of the invoice method selected.

22. Milestones added to a project and scheduled with a date, now appear in the Calendar from 8:30AM to 9:00AM. 
This milestone will be created by default for the user that adds it to the project. Make sure that the calendar filter 
is not set to someone else preventing you from seeing it.

23. Milestones scheduled appear on the Monthly, Weekly and Daily calendars.
24. Fixed an issue with the Project: Billing: Transactions view; when sorted by Retainer column, view was throwing a 

java bean error on returning to view after sort was applied.
25. Updated the spelling of the reports called "Document Thumnails" to "Document Thumbnails".
26. Fixed an issue with the TimeCard view; when selecting a phase, it now shows the same % Actual as in the Project 

Summary view.
27. Fixed an issue with the data fields on the FIND screens; now dates entered, including ranges, should include the 

entire day in the range and not be concerned with the time of entry info that is also stored in a date field.
28. Fixed an issue with searches; the list view was not always being refreshed with the found records.

!

BQE Software Inc. ! ArchiOffice 2010 Change Log! Page 15 of 32



29. Fixed an issue with Project: General: Info; Add milestones valuelist only contains milestones that are set to ADD 
in Preferences.

30. Fixed an issue with the mouseover on the Project: Events add event item row; now when mousing over the Hours 
field, the tooltip says the "Duration must be entered in Hours"

31. Fixed an issue with the Project: Events layout; was throwing an error when a filter was applied.
32. Fixed an issue when deleting an Invoice; project calcs were not firing after invoice was deleted.
33. Fixed an issue when deleting an Event; in unusual situations, a SQL error was thrown on calculating the event 

conflict information.
34. Fixed an issue with the Time Slip Detail view; when clicking on an expense slip in the portal on the right, the 

markup flag was always being set, even if the slip had been invoiced.
35. Fixed an issue with the Time Slip Detail view; when the employee on a slip is changed, now after the warning the 

cursor moves into the project field.

v107
1. Changed the way the user login names are populated on the login screen to improve launch speed for very large 

firms.
2. Changed the way the Project status flag is calculated for the Billing: Projects layout, improving speed in large 

systems. Now calc is fired when a slip is changed, rather than when view is rendered.
3. Hold time is now included in the TimeCard hours for the day and week calculations.
4. Total adjustments for stipulated sum and percent of construction invoices now appear on the invoice and are 

included in the invoice total.
5. Fixed time reports that had problems when set to summary by day; date is now appearing in proper format (not 

Julian date format).
6. Fixed issue with invoicing of expenses; now the bill rate includes the markup as it did in v8.
7. Fixed issue with slip report; when set to detail, the hours were in currency format.
8. Now passing the locale to the jasper report as well, which should ensure that the currency is displayed correctly 

on the report (note: app server's default locale, Preferences: System: Formats, and client OS all need to be set to 
the desired locale, like 'en_US').

9. Extensive debugging of Word invoicing for both PC and Mac. Note: Mac Office 2011 has VBA bugs, and cannot 
be used. Mac users should use Word 2004 for invoicing.

v106  
1. Fixed an issue with Word invoicing; hourly Word invoice was throwing an error.
2. Fixed an issue with Word invoicing on Mac; invoice is now rendered in the scratch folder, then moved to the drafts 

folder. Working with older Mac Office versions, Due to an error with Mac Office 2011, this feature canʼt be used.
3. Fixed some issues in the custom reports area.
4. Fixed a bug that was throwing a bean error on exiting the application.
5. Added Contact: Misc secure notes to display. Can have an unlimited number of secure notes, with images, etc. 

Security privilege for Contacts: Lock/Unlock contact hides the secure notes.
6. Added a 4th menu option in the hidden support menu to fix invoice template issues in customer files.
7. Fixed invoice template issue in data converter.
8. Fixed issue with Statement; now shows invoices by invoice date desc.
9. Various other minor bug fixes.

v105
1. Added support for Word Invoicing.
2. Added support for custom Jasper Reports.
3. Various minor bug fixes.

v103
1. Fixed a Java error when going to the Billing module.
2. Fixed a calculation error on the Time Expense module; total hours entered for the day was incorrect.
3. Fixed an error with subMenus; throwing Java error when no accelerator key was defined (note, this was affecting 

QuickBooks integration and will not be detected in AO2010.103, as all the subMenus have an accelerator key).
4. Fixed an error that occurred when clicking on Projects>Billing>Transactions.
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v102
1. Fixed an issue with the import method (i.e. loading contact records), was having a problem when users had 

commas in their data fields.
2. Fixed an issue in Preferences>Documents>Templates; deleting a template was not working properly.
3. Fixed some issues with Time Expense security privileges, where the warning informing the user they were not 

permitted to do the action, was appearing twice.
4. Fixed an issue in marking slips approved.

v101
1. Fixed issue with Project>Submittal report when run with Sort by Client
2. Fixed issue with Time Slip with Cost report.
3. Removed the Project Department field drop down list.
4. Fixed some minor issues with the DataMigrator.
5. Fixed an issue in refreshing the Time/Exp>Detail view, when projects with/or without "use Tasks" has been 

selected. Now the Task menu is there if the project uses tasks, otherwise it is hidden.
6. Removed duplicate Preference SF330 function codes in master database.
7. Resorted the Preferences SF330 profile codes in master database.
8. Fixed some Preferences>Document>Types; removed special Mac characters from the master database, and set 

a few other types.
9. Fixed an issue with Preferences>Document>Template deletion; dismissing the confirmation dialog now does not 

delete the item.
10. Fixed an issue with the Project>Details>Team view; the Active flag check for terminated or on leave employees is 

only run if the flag is being turned on (user is being made active on the project).
11. Compound interest on overdue invoices should now be calculating correctly.
12. Create transaction security should now be working.
13. Can now create recurring event while keeping the setting of "weekend".
14. If you uncheck the security setting "create invoice", then you no longer can create the invoice from some of the 

less obvious areas.
v100 

1. Fixed another issue with the display of decimals in the timecard view.
2. Added some error handling for Contacts>Logs>Notes; clicking New note and then closing the window was 

throwing an error on Mac.
3. Template projects no longer appear when attempting to create a new transaction from Contacts>Transactions.
4. Fixed issue with summary Last Invoice Amount calculation on bottom of Billing>Projects layout.
5. Fixed issue with compound interest rate for invoicing; now interest and compound interest calculations are 

identical to v8.
v99 

1. Fixed an issue with Preferences>Projects>Teams>Roles; now displaying the role names rather than the role id.
2. Fixed an issue with Security Privilege: View Invoice.
3. Fixed an issue with Security Privilege: Create Invoice.
4. Fixed an issue with Security Privilege: View Transaction.
5. Fixed an issue with Security Privilege: Edit Transaction.
6. Fixed an issue with Security Privilege: Delete Transaction.
7. Fixed an issue with Security Privilege: Print & Preview Transaction (same effect as View Transaction).
8. Fixed an issue with Security Privilege: Print & Preview Invoice (same effect as View Invoice).
9. Fixed an issue with the New Project creation dialog; FIND contact was not working and generating an error.
10. Template projects no longer show-up in the new Transaction dialog.

11. Fixed issues with Preferences>Users>Time/Expense Options; these settings should now be getting applied to the 
Time/Exp>Detail view, like Previous Record, Current Date, Blank, etc. Please test slip creation carefully to ensure 
we have not broken anything.

12. Fixing the number of decimals to 2 in the TimeCard and ExpenseCard view's top section. User reported showing 
more decimal places.
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13. New overpayment handling process. Scenario: If you have an overpayment of 5000 (project balance = -5000), 
and create a new invoice for 4000, the overpayment transaction is changed to 1000, an new transaction for 4000 
is applied against the new invoice, and the project balance is -1000. Major business rule change; please test fully.

v98
1. Fixed some time/expense security settings on various forms; were not being enforced.
2. Fixed the department label issue; now setting the label in preferences to something like "office" will be applied to 

the Project>Details and find forms.
3. Fixed an issue with the time and expense card views; now if you do not have the privilege to Edit Others Slips, 

you cannot select another employees slip and have it load into the Update slip row (action is ignored).
4. Fixed an issue with the Payroll report; should now be summarizing correctly.
5. Fixed an issue with launching labels or envelopes from the Contact>Detail address tab; will now launch with 

the .doc file extension (assuming that is what you specified as the create type in Preferences).

6. Fixed an issue with Transactions when paying multiple invoices in one transaction, a rounding error was 
preventing the remaining funds = 0 after all invoices were paid off.

7. Fixed an issue with Payments from Retainer; was not reducing the retainer balance properly. 
8. Clarification on drag and drop of phases, job codes and tasks; you cannot drag and drop a child and try to make it 

a parent, nor can you take a parent and make it a child. Use the add buttons to add parents and children, then 
drag and drop to organize them (change sort order) or use the arrow buttons to move them up or down.

9. Payments to retainer are restricted to the project, payments from retainer can be applied against an invoice.
10. Credits can be applied against a project (in which case they are applied to the next invoice generated), or they 

can be applied against an existing invoice.
11. Overpayment transactions now being exported against checking account and accounts receivable.
12. Running some SQL code in the updater to clear any markup values from Time records; implemented code to clear 

markup on Time/Exp>Detail view when toggling from expense to time.
13. Existing milestones will now appear on the calendar.
14. Fixed an issue with updating of the project contact roles in the updater script; was not updating all project 

contacts. Should now be displaying the role name rather than an ID value.
15. Cost on slip report with cost will now match the cost on the projects QuickView; was including all expenses, and 

should only have done reimbursable expenses.
16. Fixed QuickView cash and accrual calculations. Should be properly accounting for the credits.

v97
1. In Preferences>Users>Details; Project member role now shows type ahead field, same as in 

Project>Details>Team view.
2. Fixed an issue with the Periodic Totals report; now running the report sorted by Day does not use the Julian date 

format, but the users format specified in AO.
3. Prepared a new Payroll report, which includes Internal time (additional job codes). Please check carefully.
4. Fixed an issue when creating a new document for a project for the first time after logging in, and the user clicks on 

the project name to assign the doc to a different project, the template projects no longer show up. Only Active 
projects will appear.

5. Implemented sequence numbers for project documents when documents are created from templates that are 
sequenced. User can override the sequence number, but only numeric sequences are supported (not alpha 
numeric).

6. Updater will run some code that will refresh the Project Contact roles. The roles should work properly moving 
forward.

v96
1. Fixed an issue with the Backup Hourly layout; added Sat & Sun to days of week. Clarification: Between means 

the time from to the time to, in which backups will be run. For example, 9 and 19 would mean between 9am and 
5pm. Frequency means every x hours, so a frequency of 1, would mean it will be backed up every hour, between 
9am and 5pm. Then, specify what days of the week.

2. Further debugged duplication of project with custom documents path; new project is now created with the same 
folders as the original, but in the default AO docs location (by Project Number). Needs to be tested well, as it will 
affect lots of areas. I tested it quite a bit, but others need to as well.

3. Fixed an issue with the TimeCard view after immediately logging in; project with tasks did not have the task menu 
appearing.
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4. Fixed an issue on the TimeCard view; new records were not getting either the team member rate or a custom job 
code rate.

5. Updated the Project Phase actual rate calculation; parents now show null and do not calculate a rate from the 
children.

6. Clicking the red new button in the Time/Exp>List view now takes you to a new blank record.
7. Creating new Time cards now uses the User's preference; time, expense, or previous record.
8. Fixed issue with testing document templates; doc date is now todays date. Feature request needed for link to edit 

the document template from this layout.
9. Changed label in Project>Billing>Summary from "Fees/Exp" to "Fees+Exp".
10. Fixed an issue with Preferences>Users>Details>Projects portal; was not showing the role. Should be displayed 

correctly now.
11. Changes or additions to Preferences>Billing>Accounting Codes are refreshed immediately after leaving the 

layout.
12. Drag and Drop of Project>Documents from one folder to another was moving the item you dragged as well as the 

first item in the folder (because it was also selected by default). Now, when drag & drop is started, no rows are 
selected in the table, hence only the one(s) you select will drag and drop.

13. Overpayment now shows up as a negative project balance.
14. A negative project balance now is applied against the next invoice generate, as an amount paid and reducing the 

invoice remaining balance (or paying it off in full).
15. Fixed issue with Project>Billing>Options Adjustment to Total for Time; now if you have two types of time on your 

invoice (basic and additional), the only half the adjustment you entered (ie -$100) is applied to each type of time, 
so that the total adjustment is what you entered. Before it was double what you entered.

16. Fixed issue with Invoice Total calculation when adjustments were involved; now corrects the right total regardless 
if both basic and additional services are invoiced and an adjustment to total time is used.

17. Fixed a display issue with the Profitability Accrued Report.
18. Fixed an issue related to deleting a child Job Code in the Project>Details>JobCodes layout.
19. Fixed an issue with the Slip Report with Cost; was not displaying the correct Cost$.
20. Fixed an issue with the Project>General>QuickView; only non-reimbursables are now included in the cost 

calculation.
21. Fixed an issue with the Project>General>QuickView; credits were not being included in the Net Billings or Total 

Paid calculations for the Accrued and Cash views.
22. Fixed an issue with the Profitability Report Accrued; was not calculating the profit correctly. Fixed some issues 

and should be working better now.
23. Fixed several issues to do with Retainers on Invoices; showing retainers, not showing retainers, payments to, 

payments from, etc.
24. Now forcing retainers to be applied only against projects; support requested that we only allow retainer 

transactions to be created against a project, not invoices. So, the invoice button is now disabled for retainer 
transactions.

v95 
1. Fixed an issue with adding new account codes in Preferences>Billing>Accounting; was throwing a SQL error.
2. Fixed an issue with Templates added to a folder in the existing Preferences>Documents>Templates structure, and 

then later trying to use that template for new doc creation in a project.
3. Removed a development button from the Project>Checklists view.
4. Implemented some code to set the default sort order for all Preference>Project>Tasks; this allows them to be 

moved up/down properly.
5. Fixed an issue with currency formatting, when using currencies that have the symbol after the number, like 

"#,###.## E". Was displaying only 1 decimal place in some views. Fixed now.
6. Fixed an issue with the Reports view, when attempting to run a report with "Use current found set" where the 

foundset is 0 records. Now displays a message that there are no records, and to try a search. Unchecks the "use 
current found set" checkbox.

7. Added some more error trapping to the Backup area. Also fixed some malformed SQL issues for creating the 
backup job when using the time 12 am.

8. Fixed issue when doing Project>Documents Sync; Email folder was still be deleting, but underlying emails were 
not. Both the folder and the emails should now be ignored in a sync.
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9. Fixed an issue with Slip billing rates; first the billing rate for the team member is used, and then if there is a job 
code rate, then that is used instead.

10. Fixed an issue with the Time/Exp>Detail layout, where when selecting the a project, the team members role was 
showing a number instead of text. Note: You may have to go to the project and reset the team members role.

11. Parent phases / job codes no longer show a billing rate. The argument was presented, that because the children 
may or may not have a billing rate, just dividing the sum of the children's fees by the sum of the children's hours, 
was not an accurate representation of the true rate.

12. Fixed an issue with Project>Details>Job codes drag and drop; now working properly.
13. Implemented code to check for missing / add if necessary i18n tooltips for start/end time on Calendar>Detail view.
14. Removed the Preferences>System>Format option for Time; forcing everyone to use 12 hour time format (am/pm) 

until some key bugs can be resolved that are due to 24 hour time format.
15. Fixed an issue with the Preferences>System>Backup times for hourly schedule; the end time cannot be before 

the start time. Error is displayed and the End time is cleared.
16. Fixed an issue discovered when duplicating a Project with custom document folder path; now the new Project will 

be created using the default filing system. Folders for the duplicated project are created on the fileserver.
v94 

1. Fixed issue with Project duplication; occasionally was throwing an error during document duplication; added 
check to avoid error.

2. Fixed issue with Time/Exp>Detail view; gray shading removed from some checkbox areas so that they are 
transparent.

3. Fixed issue where a terminated Project Member was still appearing in the available employee list of a Time slip 
entry. Now employees designated as Terminated or On Leave in Preferences cannot be used on Time slips.

4. Fixed issue with non-reimbursable expenses adding the qty for the expense to the hours. 
5. Fixed issue when duplicating a project; Project Summary view was still showing invoiced percent and invoiced 

hourly from old project. Now cleared on duplication.
6. Fixed issue with scheduling Milestones in the Project>General>Info: Milestones portal; now when setting a date 

for a Milestone, the Milestone should appear on the calendar (assuming your filters are set correctly)

7. Fixed issue with accounting export; Payments were not being flagged properly as having been exported.
8. Fixed an issue with Project>Billing>Options view; Parent phases were not properly computing % complete current 

invoice or current invoice amount when child phases were being used.
9. Fixed issues with rounding numbers on Invoices; now should be displaying and calculating the cents properly 

when fractional percentages used for billing, like 96.37% of a phase.
10. Fixed an issue where a credit was not appearing on the next invoice when making an overpayment against a 

project. Now, any invoices with balance due are paid off first, and the overpayment will appear as a credit on the 
next invoice.

11. Fixed an issue with the accounting export; invoices being exported were counting the expenses twice, and hence 
were not balancing.

12. Fixed an issue with entering overpayments against a project; now all invoices are paid off, and the remainder is a 
credit on the project. The user has to select the credit account to use in the process.

13. Fixed an issue with retainer transactions; where not properly appearing in the transactions list.
14. Fixed issues with project calculations dealing with rounding of digits.
15. Fixed issues with invoiced amount calculations when phases and subphases were involved.
16. Fixed issue with EmployeeQuickView; should now be functional. Report will have to be created after this next 

release.

17. Fixed issue when creating new Expense Slip; when on the Time/Exp>Detail view, and you toggle from Time to 
Expense, the markup flag will be set (functions the same way as in the Expense card view).

18. Fixed issue with QuickBooks export; non-reimbursable expenses are now ignored and not in the export (exactly 
like v8).

19. Fixed issue with changing account name / code in Preferences>Billing>Accounting layout; now when the name or 
code is changed, all transactions not yet exported are updated with the new code changes.

20. Fixed issue when finding a single transaction; the search is performed, the user is returned to the prior layout, and 
then the transaction detail dialog is shown. Previously, the user was shown the dialog and left on the search 
screen.
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21. Fixed issue when finding a single invoice the search is performed, the user is returned to the prior layout, and 
then the invoice detail dialog is shown. Previously, the user was shown the dialog and left on the search screen.

22. Fixed an issue with the Billing>Transactions report; now functioning correctly and showing credits in the correct 
column. Did not find any problem with date searches.

23. Fixed an issue with the Transactions>Detail dialog; you are now able to check/uncheck the "exported for 
accounting" flag. All associated transaction items for the transaction are affected.

24. Fixed an issue with the Project Contacts Directory report; now functioning again.
v93 

1. Fixed issue with Document>List view menu; now should be showing up.
2. Fixed "Correspondence" spelling in Contact List view; was not refreshed in the i18n table on last attempt.
3. Had to remove feature allowing the user to try entering a new project number in the new project creation process. 

Could not get it to work if the user cancelled out in the callback. User must restart the new project creation 
process if project name or project number are not unique.

4. Fixed an issue with calculations for actuals; were not adding the non-reimbursable hours and $ correctly (adding 
hours only).

5. Fixed issue were omit up/down/current were not always working consistently. Tried a few more tricks to make it 
more consistent.

6. Fixed an issue where creating a new Project from the Contact>Detail view, after adding a new contact, did not 
refresh the billing client field on the Project>Details view of the newly created project.

7. Fixed an issue with Project Contact roles not displaying correctly in the Note/Submittal/Drawing/RFI Add Contact 
dialog.

8. Fixed an issue with Project>Checklist>Tasks: Complete Date was not being shown.
9. Fixed an issue with duplicating project; calculations are now cleared in the new project.
10. If you do not check "Use Tasks for Time" on the project, then you cannot use Tasks for Slips on either the Time/

Exp>TimeCard or Time/Exp>Detail layouts.
11. Fixed issue with adjustments on Invoice applied to total by time, expense or total.
12. Fixed an issue with list views; when an error is detected (usually due to some user saved settings for that view), 

the table will automatically reset itself and try rendering a second time.
13. Fixed an issue with Syncing; if there are no records to sync, the sync will be allowed to proceed with no records, 

and will not throw an error. There is always the chance that there are records in Outlook already, that the sync will 
bring in to AO on the return.

14. Fixed an issue in the new Transaction dialog; date column in the bottom showing the individual transaction items 
now shows the transaction date, instead of the create date.

15. Fixed an issue with the rate used for a TimeCard; now if a job code rate exists, it trumps the employee bill rate on 
the project. 

16. Fixed an issue with the ExpenseCard Emp. Reimb. checkbox; now when adding a new expense record, this 
checkbox stays checked if selected.

v92  
1. Fixed Project>Billing Summary report; when Detail was selected for the output, Project No was displayed for a 

column instead of Invoice No.
2. Fixed Billing>Billing Summary report; when Detail was selected for the output, Project No was displayed for a 

column instead of Invoice No.
3. Fixed a dialog when adding employees to a project team, and there are no more employees that have not already 

been added.
4. Fixed an issue on the Project>Details>Job Code layout; when editing the name of a job code, after leaving the 

field, the record was moving to a different record.
5. Fixed an issue on the Project>Details>Phase layout; when editing the name of a phase, after leaving the field, the 

record was moving to a different record.
6. Fixed a typo for a provided system default phone number format selection from (###) ###-### to (###) ###-####.
7. Fixed issue when applying subsequent phone number format to all phone numbers; method was not recombing 

the phone number + extension before the split was done again.
8. Fixed an issue when Project type was changed from billable to internal, etc.
9. Fixed issue with Contact>Documents portal; now sorting by document date desc rather than create date desc.
10. Fixed an issue when adding new custom address tabs in the Contact>Detail view; default phone number fields 

were not being auto formatted when data was entered into them.
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11. Fixed issue on Billing>Billing Statement report; now displays client address info in top left. However, this report 
does not break out invoices by project, it simply lists them, exactly like it does in v8. Feature request needed if 
functionality is to change.

12. Implemented a new feature, to load the tasks from a template phase, for a custom phase with the same spelling. 
So, if you add a custom phase called "01 Pre Design", and that is spelt exactly as a template phase, it will match 
up, and the tasks can be loaded.

13. Fixed calendar hover info dialog; now shows information about the event, even if no attendee has been assigned.
14. Fixed issue with Project>Details>Milestones; when date is change, event on the calendar bean is updated.
15. Fixed issue with Project>Details>Milestones; rather than the milestone starting out as an all day event, it will 

appear at 8:30 AM 9:00 AM on the scheduled day. This will cause less clutter on the calendar.
16. Fixed issue with Billing>Detail Bill report; was not always showing reimbursable expenses. Turns out sometimes 

markup was null, so needed to use COALESCE(markup,0) in SQL for report.
17. Fixed reports for Billing area; International currency support, International date support, proper page numbering 

for page counts > 100.
18. Fixed invoice reports, including proper page numbering for page counts > 100, as well as wrapping phase and job  

code names.
19. Fixed reports for Contact area; International currency support, International date support, proper page numbering 

for page counts > 100.
20. Fixed some issues with Report>Project: Budget vs Actual report; parents were being included in calculations.
21. Fixed some issues with Report>Project: Budget vs Invoice report; parents were being included in calculations.
22. Fixed some issues with Report>Project: Budget Hours report; parents were being included in calculations.
23. Fixed Payroll Report. Calculations for different report settings now working correctly. Clarification: this report only 

does regular hours and overtime hours, it does not report on Internal time (works exactly like v8; anything else will 
need a feature request).

24. Fixed all Project reports; International currency support, International date support, proper page numbering for 
page counts > 100, phase/sub phase and job code/sub job code names.

25. Fixed all Time reports; International currency support, International date support, proper page numbering for page 
counts > 100, phase/sub phase and job code/sub job code names.

26. Fixed issue with Contact menu "New Record". Now new record is added, and the cursor is focused in the first 
field.

27. Fixed an issue with refreshing the job code and phase display names (like "01 PreDesign: 01A Sub Phase"), 
when adding/editing phases/job codes. Updater SQL will run calcs on all initially. These display names showing 
hierarchy for sub phases/sub job codes is used in reports and invoices now.

28. Fixed an issue with creating documents for a project using templates in redesignated destination folders (like 2K 
Meeting Memo).

v91
1. Fixed issues related to applying payments to Projects where invoices exist, as well as deleting the payments. 

Where there are existing invoices, the project payment will be applied against those first, and any left over amount 
will be a credit on the project.

2. Fixed issue where the security object in the user's cache was not being updated properly. Now just building the 
security object each time someone logs in.

3. Fixed some issues with EO/AO button tooltips.
4. Fixed an issue with chart filter arguments not refreshing correctly. Now if you try to chart 2 months of data, the 

filter is applied properly to the data.
5. Fixed issue with the list view refreshing when adding or removing event contacts.
6. Fixed issue with Project>Details>QuickView, where the profitability was not being refreshed when switching from 

Accrued to Cash.
7. Fixed an issue with the slip timer. Now uses the start date/time and the end date/time, incase the timer crosses 

over midnight.
8. Fixed issue when changing invoice method from stipulated sum to percent of construction. If current budget is set 

to $fees, then warning is given that the budget must be changed to %. Entering a total construction cost and % 
calculates the total fees and budget available, so % can be allocated for phase budgets.

9. Fixed issue with Calendar Bean milestones. Milestones were not appearing on the calendar. Fixed the issue and 
added some code on the update to fix the problem.
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10. Fixed issue with Calendar Bean event type filter; was not being populated with the list of events available on the 
calendar.

11. Fixed issue with refreshing the Calendar Bean, when changes were made to milestones in Projects (like change 
date), or when changes were made to events in the detail view.

12. Calendar list view will now refresh if changes are made to milestones in Projects.
13. Fixed issue to sort the Preferences>Billing>Account code lists.
14. Fixed issue where the accounting export combo-box was not large enough for the Mac.
15. Fixed size of text in Preferences header to accommodate "ArchiOffice Preferences".
16. Fixed issue when re-logging in; if you cancel, you are returned to the Home screen and the application does not 

exit.
17. Fixed issue when adding new contact record; it is now added to the end of the foundset, not the start.
18. Fixed issue with navigation footer so it says record 14 of 14 (as an example), rather than 1 of 14, when a new 

contact is added.
19. Fixed issue with editing the 6th address tab name for a Contact record; it is now editable.
20. Changed the select contact dialog when creating a new project; now only contacts with an address flagged for 

billing.
21. Changed the new project creation process from the Contact>Detail view; now a dialog informs the user if no 

billing address is identified and the project creation is aborted.
22. Fixed an issue where the % phase completed was not being refreshed when slips were added in the time card 

view.
23. Fixed an issue when creating an invoice in some time zones, the invoice date was 1 day prior to that entered in 

the new invoice date dialog.
24. Fixed an issue in Preferences>Project>Tasks; you can now add task types to new phases, then you can add 

tasks to the task types for the phase.
25. Fixed the spelling of the word "Correspondence" in the header row of the Contact list view.
26. Implemented redundant column to backup phase and job code parent id information, in case the tree view bean 

drops the hierarchy. If this happens, simply viewing the Project>Details>Phase or Project>Details>JobCode views 
should restore the hierarchy of parent/child automatically.

27. Fixed an issue when selecting ALL in the custom reports filter, only the users reports and other users public 
reports should be visible.

28. Fixed Reports>Contact: Documents: List report; includes all documents except for folders.
29. Fixed Reports>Contact: Documents: Thumbnail 1 3; these reports now exclude folders, email attachments and 

documents that have no image.
30. Fixed Reports>Project: Documents: List report; includes all documents except for folders.
31. Fixed Reports>Project: Documents: Thumbnail 1 3; these reports now exclude folders, email attachments and 

documents that have no image.
32. Fixed Reports>Project: Master RFP Checklist report; now working.
33. Fixed employee sorting for reports; was being done on FIRSTNAME + LASTNAME, now sorting LASTNAME, 

then FIRSTNAME.
34. Fixed issue where Project templates were being included in reports; now templates are ignored from reports.
35. Fixed all reports that where sorting by MonthName & Year when group by MONTH was selected, now sorting by 

Year & MonthNumber.Numerous Time reports involved.
36. Fixed Report>Project: Profitability Report Accrued; calculations now include the hourly phases. Please verify this 

one is working correctly.
37. Fixed Report>Project: Profitability Report Cash; % Profit calculations are now being computed correctly for all 

sub-summaries and grand total.
38. Clarification: occasionally in the report display criteria, radio buttons are used rather than checkboxes. There is a 

technical reason why the parameters need to be radio buttons, and not checkboxes, so they will remain as is 
(which is working fine). Would take a lot more investigation and potential re-writing to change it.

39. Clarification: Project Checklist report appears to be working fine. Was reported in TT that it was showing all tasks 
in triplicate, but this is not reproducible in files tested in development.

40. Clarification: Invoice page breaks; Due to the limitations of Jasper Reports, it appears that the invoice template 
type b always breaks to a second page, even if very little information is there to display. I have spent several 
hours attempting to minimize this, but have been unable to find a solution. Has to do with sub reports taking up 
space on the layout whether they have data or not. We will have to revisit this in the future.
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v90
1. When using Tasks for time, tasks will show up that meet the following criteria: any status other than "Completed" 

or "Not Applicable", that are assigned to the user, or have been assigned to no user.
2. Fixed issues when omitting records with a sorted list view. Note: I believe this can be made to still fail, but that 

appears to be a bean bug and has been reported to the vendor. It works 95% of the time, so we have to live with 
this for now.

3. Fixed issue to update the Contact>List view when changing contact details in the Contacts>Details layout (i.e. 
contact type).

4. Fixed issue with sorting by Employee in the Time/Exp>List view; should now be sorting the usernames correctly 
(depending on your username format).

5. Fixed issue with updating an existing slip in the TimeCard or ExpenseCard view; now functioning again. Note: 
Slips that are draft, billed or approved cannot be updated.

6. Fixed issue with totals on Time/Exp>List view not being calculated properly. Difficult to reproduce, but more code 
has been added to ensure that the slips shown are included in the calculation. Please report any additional 
problems you find.

7. Fixed issue with Update: Charge Status on Time/Exp>List view; now charge status can be set, including no-
charge and hold (hold refreshes icon).

8. Enhanced the Time Find view, to allow searches for slips requiring approval and whether or not they have been 
approved, as well as slips that are employee reimbursable, that have or have not been paid out to the employee. 
By using this new FIND capability, and the standard slip report, users reporting needs should be met.

9. After finalizing or deleting an invoice, the Contact>List view billing icon is refreshed.
10. Duplicating a project (whether from template or normal), will take the user to the new project and refresh all the 

calcs.
11. Implemented drag and drop for Project>Details>Phases and Project>Details>JobCodes; now you can drag a sub 

phase to a new parent in the tree, for example, then use your move up/down arrows to position it where you want. 
Warning will appear if the phase you are dropping onto is in use, with override at your own risk option.

12. Implemented support console into hidden support area accessible from the login screen (option 3). Will be useful 
to investigate issues in the field and fix them in the field.

13. Fixed an OS check issue with setting Preference>Document>Paths.
14. Fixed an issue with milestones not being added in the right order, and then later changing the order to use the 

date rather than the original sort order.
15. Fixed an issue with stipulated sum invoices in not getting the tax applied correctly to the fixed fee portion of the 

invoice.
16. Adjusted some field widths for certain invoice methods on Project>Billing>Options, to accommodate the Mac 

interface.
17. Fixed an issue when canceling the new Document creation process.
18. Added a large number of additional fields to the document export so that the RTF templates can use the data.
19. Modified the RTF converters field map to handle a large number of additional fields.
20. Fixed an issue with the document_date not being used for the list view or when the document was being created 

(was using current date).
21. Implemented ability to move from record to record in Dialog view (i.e. Document info view) using the keyboard (on 

Windows, use ALT + arrow UP or arrow DOWN; no idea on Mac).
22. Installed new Records menu for Documents List view that includes Delete & Delete All.
23. Fixed issue with document sync; now ignores email document records and email folders.
24. Fixed issue where module menus were not being restored after closing the Documents Info dialog.
25. Fixed issue with Project>Documents filter checkbox; should hold the users settings.
26. Fixed issue with Document>Templates view; when template file is deleted, the tree is re-initialized to show all 

remaining records.
27. Fixed an issue with Preferences>System>Backup: Run Now when backup job had been deleted from the files, an 

error was thrown. Now, if no backup job is detected, the interface is reset and the user is asked to setup a backup  
job.

28. Added "Hours" label after the allocated field on Preferences>Projects>Phase Details, so people know to put in 
hours into this field.

29. Added flag to use tasks for time on all new projects on the Preference>Project>Tasks layout.
30. Enlarged field size of fields on Preferences>System>Backups to accommodate the Mac interface.

!

BQE Software Inc. ! ArchiOffice 2010 Change Log! Page 24 of 32



31. Implemented callback to method that asks the user to confirm or enter a project number, during project creation. 
Now, when the number is detected as being used (and needs to be unique), it will ask the user again to enter a 
vaild number, rather than starting the project creation process over again.

32. Fixed an issue when nonReimbursable expenses that were entered were incorrectly calculating the hours in the 
Project>Billing>Summary view (was adding $ to the hours).

33. Fixed an issue where changes made to Project Type, Project Status and project Leader, were not refreshing the 
Project>List view on next visit.

34. Fixed issue that was not refreshing the Project>List view when a project was deleted from the List view.
35. Fixed an issue where Project>Checklist: Phase budget amounts were not being calculated initially when a new 

project was created with tasks that had budgets. Now the phase is being calculated upon project creations.
36. Fixed an issue where Project>Checklist: Task filter settings were not being preserved when you left the layout and 

returned later. 
37. Fixed an issue in Project>Checklist: when the Status filter is set to Pending, for example, and a task is marked as 

Completed, the view now refreshes.
38. Fixed an issue with Project>Checklist>Task Detail view, where variance was not being calculated to two decimal 

places. Also changed hours to display two decimal places for the phases on the Project>Checklist view as well.
39. Fixed issue where Parent Phases were not properly calculating the %Actual and %Invoiced of their child phases. 

Affects Project>Billing>Summary.
40. Fixed an issue where the Project>Billing>Options layout was not showing the correct Total Budget Percent (was 

not taking into account hourly phases). This was also affecting the Invoices. Now all layouts and the invoice will 
show the same total as Project>Billing>Summary.

41. Fixed an issue with the Time/Exp>List view Update>JobCode and Phase menus; was not recalculating the old 
JobCode or Phase amounts that the slip was moved from (was calculating fine for the new ones it was getting 
moved to).

42. Fixed an issue with the Project>Billing>Options layout where the Total for the Amount Invoiced column was not 
including hourly phases. Now shows total invoiced for the phases (fixed and hourly).

43. Fixed an issue where the documents table was not refreshing when user navigated from project to project with 
"show all as one list" was set in the Project>Documents view.

44. Fixed an issue with the Project>Billing>Budgets layout, where the scrollbars were being chopped off by a few 
pixels; may have resulted in some display issues on some Macs (depending on OS theme setting?).

45. Inserted "Retainer" account into Preferences>Billing>Accounts>Other; was missing and needs to be there. It will 
need to be configured by the users, and was not part of the conversion process.

46. Extensive debugging/Testing done on Document Syncing. Should be very solid now. Please test on Mac.
47. After sync, project name, project number and contact info are all calculated and displayed if immediately viewed 

in the Documents>List view.
48. Implemented warning message for possible long process, and use the busy screen, for the update all thumbnails 

button on the Documents>List view. Images and PDFs thumbnails are updated by the process.
49. Fixed issues with QuickBooks export of transaction items. Now transactions are exported exactly as they were in 

v8, including the order of credits/debits.
50. Fixed an issue of missing Phase/Job Code join records on new Project creation, when extensive use of sub-

phases is employed.
51. In Project>Details>Phases, when using sub-phases, the associated job code tree is hidden when a parent node is 

selected, since associating job codes to a parent is not relevant; only the children can be used.
52. When creating a new Project, if you use a number other than the next in the sequence, the sequence is not 

incremented (auto increment number does not get used).
53. Fixed an issue in the Data converter to address the adding of Invoice Templates Type A and B.
54. Fixed an issue with Preference>Project>Task arrows to move tasks up and down. Now functioning correctly.

v89 
1. Rewrote, tested and debugged, a data converter procedure in the documents conversion process, that improves 

performance 20x with extremely large databases (250,000+ docs).
2. Fixed issue with new template phases and job codes being added where parent_id was null rather than 0. This 

prevented the newly added phase/job code from being sorted (moved) in the tree view.
3. Added the State field back into the invoice templates; was missing.
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4. Added the red "H" icon for designating slips that are on hold. Updated the converter to set this image when 
loading v8 data, and wrote SQL to update existing clients data as well. This needs to be checked carefully, to 
ensure all filters and things are working properly now for Hold slips.

5. Changed a sql query in the new invoice procedure, to now use the last invoice_date rather than the last PK 
number, to get the prior balance from. Hopefully this will work better than assuming invoices are created in order.

6. Changed menu to read "Window" rather than "ArchiOffice" or "ArchiOffice", for all OS.
7. Changed the Project>General>Data: Description Long field to 2500 characters from 1000, per customer request/

requirement.
8. Fixed issue to refresh the Preferences>Documents>Templates tree after a folder is deleted.
9. Fixed an issue to prevent approved, draft or billed slips from being deleted.
10. Fixed an issue when duplicating a slip; now the duplicate clears the invoice number, invoiced amount, approved 

flag, approved date, approved by and employee paid out, if the original had these set.
11. Fixed issues with applying adjustments with various settings on different invoice methods. This needs to be tested 

again carefully to confirm it is now working properly for all invoicing methods and all adjustment types.
12. Fixed an issue with the Chart Designer>General layout; radio button option for PIE was not appearing on the Mac.
13. Preferences>Documents>paths for specific OS can only be set by a client of that OS.
14. Added an error message and guidance to the user to correct for header and footer images missing or of the 

incorrect type (not JPG) when attempting to create a report or invoice. 
15. Active Team members defined in Preferences to be added to new projects, are added in the order they appear in 

Preferences and have their roles and rates.
16. TimeCard Tasks should now show tasks assigned to the current users, as well as any tasks that are not assigned 

to any user.
17. Checking for update availability now when an Admin user logs in. If an update is available, they will be notified, 

and be given the option to not be notified of updates when they log in (checkbox).
18. Fixed issue when creating documents from templates; SQL needed to be changed.
19. Fixed issue with new database; Preference>User: filter setting has been cleared.
20. Fixed issue with new database; Preference>Project>Job Codes; default rate is null not 0.
21. Fixed issue with new database; Preference>Project>Defaults; "test log" has been removed from Note Types.
22. Fixed issue with new database; Preference>Workgroups>Reports; all reports are now available to the 

Administrator.
23. Fixed issue with new database; Preference>Documents>Templates; associated all template docs to be created in 

Word or Excel as the initial default.
v88 

1. Old v8 project numbers that did not support a separator, like "0817" are now allowed for the creation of new 
projects.

2. Fixed an issue with Hourly Invoices; Summarize by Phase and Summarize by Code were reversed.
3. Fixed an issue with Invoices; Summarize by Role was not sorting correctly. 
4. Fixed a rounding issue when applying payments against invoices; remaining invoice balance had more significant 

figures (like $2048.7799999999997).
5. Changed menu to show "Window" on Mac, and [AppName] on PC.

v87
1. Reoccurring events are now turned on. Please test.

v86
1. Made a speed improvement to the converter; now uses SQL inserts for email attachments rather than Servoy 

(improved the performance by hours with large test file of 19,000 email attachments).
2. Added version number to the converter's "conversion.log" file. We can now tell which version of the converter they 

ran.
3. Fixed an issue with the contact name formatter that was wiping out contact name values. 
4. Added SQL in the updater routine to restore any missing contact_name field values that are missing (due to 

conversion with v85 or anyone who applied the contact name format).
5. Fixed an issue with a relationship that is used in Project>Documents causing multiple folders to show from time to 

time.
6. Fixed and issue with the converter to replace any ":" in the mac documents path and link path with "/", which is the 

equivalent in java.
v85
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1. Running some SQL to correct for conversion problem where clc_contact_name_display (field used in 
Contact>List view and Project Billing Client) is Null or ",".

2. Lots of client-server dubugging of the converter to address problems being reported by support with some client 
files

3. Changed the Home: Contacts portal to use "clc_contact_name_display" instead of "contact_name".
v84

1. Re-runs all the project calcs.
v83 

1. Fixed typo in URL used with EO version of "Help>Online Manual".
2. Changed menu "Help>About" to use the app name and dynmically display like "Help>About ArchiOffice".
3. Changed menu "Help>Visit us on the web" to use the app name and dynamically display like "Help>Visit 

ArchiOffice on the web".
4. Fixed an issue with QuickBooks export. Taxes were not being exported as separate line items for tax1 and tax2.
5. Fixed an issue with QuickBooks export. Reimbursable expenses were not exporting as a negative number, hence 

the entire transaction did not = 0 (Credits = Debits).
6. Fixed an issue when a new template is attached in Preferences>Document>Templates, and you delete the new 

template, it is removed from the Templates folder, not the original source location where it was added from.
7. Fixed an issue with the move up and move down arrows on the Preferences>Document>Templates layout. Now, 

after moving a file/node up/down the tree refreshes.
8. Fixed an issue with the move up and move down arrows on the Preferences>Document>Templates layout. No 

Java error is thrown if nothing was selected and a move is attempted.
9. Fixed an issue when creating a new Document; when the new document creation window opens, if you hit cancel, 

a blank document record is no longer left behind (used to show a blank record in the portal).
10. Fixed an issue with the Project>General>Data: Project Team member roles; now using the proper value list to 

display their role as defined on the Project>Details view.
11. Fixed an issue with Omit Up, Omit Down and Omit Current on List views; when list view was sorted by some 

column, it was not refreshing after the omit was applied.
12. Added the version number information to the status bar of most screens.
13. Fixed an issue with the Project>Slips view; clicking on an employee now filters the slips in the portal below.
14. Fixed an issue with Reports Custom Reports filter; now private reports only appear for the user that created them.
15. Fixed an issue with Project>Documents tree move up and move down errors; now the nodes move in the sort 

order correctly without affecting other nodes.
16. Fixed an issue with the Project>Checklists Task portal, where the move up and move down arrows were not 

refreshing the tasks in the portal.
17. Fixed an issue with the Project>Billing>Summary view; actual values for a parent phase were not summarizing 

the the children (sub phases).
18. Fixed an issue with the Project>Billing>Summary view; non-reimbursable expenses were being added twice.
19. Fixed the SQL for the Slip Report with Cost; should display the correct totals for Time and Expenses now, in both 

the summary and detail views.
20. Fixed an issue with the Project>General>Data: Photo folder; when clicking the Folder link, the dialog that opens 

now shows the images in the folder the user selected to use.
21. Added more Project related fields to the Project Task Find layout.
22. Changed "<<No Charge>>" to "No Charge" on the invoice templates. This needs to now be tested for all invoice 

summary variations to confirm the change has been made everywhere.
23. Calendar items, like ToDos, can now be created without any Date being set. If you clear the date, the start/end/

duration is cleared as well, as it cannot be calculated without a date. These events, of course, will not show up on 
the Calendar, since they have no date.

24. Fixed an issue in duplicating an Expense slip; the "apply markup" checkbox now retains the setting from the 
original expense slip.

25. Fixed an issue in license validation; could not validate when 12 was used as the number of licenses. So the code 
generated by the CRM now validates as in: McKinley Dang Burkart Design Group , 12 Users , DUA5-VZ6E-5SE8-
EJUU-EXGS-8LL3-F6DD

26. Changed the Project>General>QuickView to now show Total Payments Credits for Total Payments in the Cash 
view, and Total Invoiced Credits for Total Billings in the Accrued view

27. Fixed some Mac layout issues on Preferences>System>Backups; Mac users can now clearly see all the fields.
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28. Fixed an issue with Workgroup privileges; now making a change to the workgroup updates those users in the 
workgroup that do not have that privilege set to some custom setting.

29. Fixed an issue with missing table and table columns; now being added by SQL during the update process. This 
will require the server service to be restarted, or the server to be rebooted, to pickup the table changes.

v82
1. Made some changes to the data converter to handle record delimiters better; were having some problems with 

some clients.
2. Implemented changes to menu "Help>About ArchiOffice" to "Help>About", so that ArchiOffice can be 

accommodated (or future flavors). Now launches the appropriate URL for the app flavor.
3. Implemented changes to menu "Help>Visit ArchiOffice on the web" to "Help>Visit us on the web", so that 

ArchiOffice can be accommodated (or future flavors). Now launches the appropriate URL for the app flavor.
4. Implemented changes to menu "Help>Online Manual". Now launches the help web site for the appropriate app 

flavor.
5. Quit application button now displays an appropriate message for the app flavor.
6. Implemented changes to menu "Help>Contact Sales"; will now go to sales@ArchiOffice.com or 

sales@ArchiOffice.com, depending on app flavor.
7. Implemented changes to menu "Help>Contact Support"; will now go to support@ArchiOffice.com or 

support@ArchiOffice.com, depending on app flavor.
8. Changed the % column converter method to now allow "25.52 %" to be entered in the budget view, and the totals 

will be calculated correctly for parents. Summary view will show "26 %" in this example, since no room for decimal 
places exists. Servers will have to be stopped and restarted for changes to be in effect. You may need to reenter 
values for changes to be affected (for parent to calc correctly).

9. Fixed an issue with the History recording method that was throwing an error in unusual instances.
10. Changed how the CAP and CAP AMOUNT is used in hourly invoices; now the CAP should be applied to all 

phases that are part of basic services (including phases set to hourly), and exclude any Additional Services job 
codes (opposite of how it worked before). Please test carefully to verify.

11. Fixed an issue with document syncing. Should now be working better on Mac. Please test carefully to verify
v81

1. Implemented a new procedure to refresh two calculations used in the Contact>List view when the user first logs 
in; the Primary Communication and Billing Status checkbox (indicates whether or not invoices are current(green), 
overdue(red) or is even setup for billing(checked)). These need to be refreshed each time the user logs in.

2. Fixed an issue with the Time/Exp>List view; after deleting all records in the list view, the totals at the bottom are 
refreshed. The List view should reload itself with the user's "MyList" of records. Please provide screenshot and 
details if the problem still exists. 

v80
1. Fixed a currency format issue on the Time/Exp>Detail view; bill rate and total with tax now use the currency 

format set in Preferences.
2. Fixed an issue with DSE/DPE invoicing; rates defined in Preferences for the user were not being applied.
3. Fixed an issue with adding expenses from the Expense Card view; working again.
4. Fixed an issue with Project>Documents Sync to trap for an error if the folder cannot be found.
5. Fixed an issue with the Project>Documents "use filter" checkbox. Now the filter can be applied, even if you have 

not specified anything to filter for.
6. Fixed an issue with the Time/Exp>List view; after using the menu option "Update Bill Rate", the totals at the 

bottom are refreshed.
7. Fixed an issue with the Time/Exp>List view; after deleting a record in the list view, the totals at the bottom are 

refreshed.
8. Fixed an issue with the Time/Exp>List view; after deleting all records in the list view, the totals at the bottom are 

refreshed.
9. Fixed an issue with loading of Project Checklists; now missing checklist items are loaded to the bottom of the list.
10. Fixed an issue with the refreshing of the Project>Checklists progress bar; now displaying the progress correctly 

when tasks are completed.
11. Fixed an issue with the Outlook sync, web address now syncing to Outlook

v79
1. Implemented security check for reports to prevent users without permission to export report data.
2. Fixed Time/Expense card eraser function; now clears all data but sets the default date to the selected day.
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3. Fixed Time/Expense card view; now when the user adds a record (or updates) in the add items row, if no date has 
been entered, the date from the currently selected day above is used.

4. Fixed an issue with Document Sync in Project>Documents view; now when the custom project folder is cleared, 
the UI is updated, and a sync process is initiated.

5. Fixed a security issue; only users with "access to preferences" can get into that area, regardless of the workgroup 
they are assigned to.

6. Fixed an issue where the last contact in the list view was not being deleted, when Delete All was run.
7. Fixed an issue with the age calculation in Preferences. Now calculating the users age correctly.
8. Fixed an issue with the accounting export; the account name now uses the format defined in 

Preferences>Billing>Accounting layout.
9. Fixed Project>Documents: New document attach Link file.
10. Fixed an issue with the Calendar monthly, weekly and detail view's User, Contact and Project Status filters. The 

filters were only showing options for what was being viewed on the calendar(after the filter was applied), and they 
now show all options.

11. Fixed a refresh issue with the Time/Expense list view where the calcs were not refreshing at the bottom. They 
now refresh every time the layout is shown.

12. Fixed a performance bottle neck on the Contact>List view with large record sets. Now, even locating a large 
number of records is very fast.

13. Fixed an issue with the record navigator not displaying the correct number of records in the list view.
14. Fixed an issue with Hourly Cap; now the cap is applied to slips allocated against the Additional Services job code 

that are not part of an hourly phase.
15. Fixed an issue in the TimeCard view so that a no-charge slip can be added from the add item row.
16. Fixed an issue with Contact Duplicate function. Now duplicates the record and moves to it when the process is 

done. Was working, but not going to the newly duplicated record.
17. Fixed an issue when attempting to delete a Contact; now will show warnings about related items (documents, 

transactions, etc.)
18. Fixed issue when attempting to delete an event from the Project>Events view; the event is now removed from the 

calendar.
19. Fixed issue when adding a new event from the Project>Events view; the event now appears on the calendar.
20. Fixed issue with Calendar>Detail view's team members and contacts not showing their roles from the project.
21. Fixed issue where non-active team members or project contacts where showing up as potential attendees for an 

Event. Now only active members and contacts will be available to attend meetings.
22. Fixed issue on Project>Details>Team; a user cannot be made active on a project if they are on leave or have 

been terminated.
23. Fixed issue when creating time slips for all users who attended an event; no longer goes to the Time/Exp>Detail 

view but stays on the calendar layout after creating the slips.
24. Fixed issue when deleting all slips; deletes all records and then goes to the list view and refreshes with "my list" or 

all records if none in my list (as per previous specification).
25. Fixed issue with Time drop down menus; Job Codes and Tasks now appearing in the order they are sorted in 

Projects.
26. Fixed issue with slip timer; calculates elapsed time correctly now when entering a start time of 11:00 am and an 

end time of 12:15 pm.
v78

1. Invoices: Non-reimbursable expenses will be set to Draft/Billed status but not appear on invoice.
2. Invoices: Reimbursable no-charge expenses appear on invoice as "<<No Charge>>".
3. Invoices: No-charge time slips appear on invoice as "<<No Charge>>".
4. Fixed issue with invoices not handling credits properly.
5. Fixed issue with invoices not handling payments from retainer properly.
6. Fixed issue with Stipulated Sum invoicing (working again).
7. Fixed issue with hourly cap not being applied to additional services when invoicing.
8. Fixed issue with hourly phase cap not being applied when invoicing.
9. Cleaned up Invoice>Detail view.
10. Project>Documents list now refreshes after viewing, modifying and closing the Documents>Detail view.
11. Fixed issues with Billing Summary report (Sum Totals).

!

BQE Software Inc. ! ArchiOffice 2010 Change Log! Page 29 of 32



12. Fixed some issues with Contact, Project, Calendar and Time list views, so they stay in sync with the detail view 
better.

13. Fixed issue with Project Balance not calculating properly.
14. Fixed issue in Billing>Projects view; last invoice is now calculated from the last invoice date, rather than 

invoice_id.
15. Fixed issue with Stipulated Sum Matrix not showing Parent: Child properly (should wrap now).
16. Fixed issue with applying International date and currency format to invoices and invoice reports (Statement, 

Summary, Matrix).
17. Fixed issue with Time/Exp>ExpenseCard and Time/Exp>Detail view when setting the non-reimbursable flag, or 

changing the charge status (Charge/NoCharge).
18. Fixed issue with creating new Contacts.
19. Fixed issue with duplicating Contacts.
20. Fixed issue with deleting Contacts from the Contact>Detail view.
21. Fixed issue with Project>Billing>Budgets view; now % can be used for setting the budget and a value like 5% can 

be entered.
22. Fixed issue with Project>Billing>Options Tax Dialog; Applying tax model to all complete and incomplete slips now 

works properly. Does not affect approved, billed or draft slips.
v77

1. Fixed an issue in Project>Slips view where calcs for slips were not refreshing when moving from project to 
project.

2. Fixed an issue with Invoices; now does not show account information on the invoice if the invoice is set to "Show 
Invoice Total".

3. Fixed an issue with Invoices so they now use the currency set in AO (like pounds for UK).
4. Fixed an issue with Invoices so they now use the date format set in AO (like International format).
5. Fixed issues with local currency and local date format for Invoice Statement, Invoice Matrix and Invoice Sum 

Totals (optional invoice reports)
v76

1. Added checkbox "Use RTF field substitution" to the Preference>Document>Template layout. This allows the user 
to specify which doc templates have field placeholders and should use substitution (like mail merge) on creation.

2. Changes
3. Fixed an issue with Project Document syncing; child records were not being associated with the correct parent.
4. Fixed an issue with the new Document>List view update thumbnail button.
5. Fixed an issue with the Expense Card non-reimbursable checkbox and the update button.
6. Fixed an issue with the Expense Card employee reimbursable checkbox and the update button.
7. Fixed an issue with the Time Card charge checkbox and the update button.
8. Fixed an issue with the Sum Totals (Summary) report not showing the correct Phases and Codes for the Project 

the user was on (either when generating an invoice or running the standalone report from the 
Project:Billing:Invoice layout) new report required.

9. Fixed an issue with the Duplicate Contact method. Contacts are now being duplicated correctly.
10. Fixed an issue with Invoice Statements not being saved in the correct folder (Drafts and Finalized).
11. Fixed an issue with Document creation; checking properly to see if a project is required or not, and if not, then 

deleting the project document join record.
v75 

1. Added a new support function to the AO2010 login screen. Clicking on the "AO" orange square in the login 
screen, will ask for a password, which will allow access to a simple support menu (will be added to in the future):
          Display all active logon, password and workgroup details. This is useful if the client forgets their password.
          Access the licensing wizard. Useful in case the user has somehow managed to lock themselves out of the 
system (or preferences), support could license an account using the wizard, so the user could login again.

2. Added navigation to the document info view. Now you can move with your mouse to the first, previous, next or last 
record, without using the keyboard shortcuts.

3. Added a button to the Documents>List view, that will update the thumbnails of all documents shown. Thumbnails 
are only available for PDF and Images.

4. Licensing Wizard screens have now changed; first screen only requests company name (no warning on name 
change if no key entered), key and # licenses; second screen just shows a list of user accounts so the user can 
click which seats get licensed (no other details about the user).
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5. Turned on the Applescript syncing function. However, this is for internal testing only at this time.
6. Put in a trap to prevent the last administrator account from being changed to a different workgroup, or to be 

unlicensed. This will prevent users from getting locked out of the preference area.
7. Approved checkbox is disabled if the slip is in Draft or Billed status.
8. OutlookOps installation dialog typo has been corrected.
9. Did some changes with Preferences Tasks layout; fields are hidden for parents with children. Confirmed Tasks 

with children are being added properly to new projects (provided the phase has been flagged to be added).
10. Fixed an issue with some root phase, job code and task having a parent_id of null, rather than 0. Implemented 

some SQL to sweep existing users data and set the parent_id = 0.
11. Fixed an issue with cap $ for Hourly not getting applied correctly. Now, additional services are capped at the 

amount, and if the draft or finalized invoice is deleted, the totals are reset for the slips to what they were before 
the cap got applied.

12. Fixed an issue with navigation for list views where it was not updating properly when selecting a row.
13. Fixed issues related to navigation, ensuring the list view and the record view stay in sync (on the same record) 

regardless of the sort order applied by the user.
14. Fixed issues related to detail views not displaying the correct values in for the navigator when moving from record 

to record.
15. Fixed the project slip report to now show the correct $ for nocharge slips.
16. Fixed issue When doing a Project>Documents sync; now new documents that are discovered and added by the 

sync will have their project data populated (name, number, etc.).
v74

1. Fixed an issue where duplicate project phase job code join records were being created by the new Project 
process. Added update SQL to correct problems in existing Projects.

2. Changed the method used for setting the Billing checkbox on the Contact>Detail view. Also, it checks to make 
sure that at least one address is the billing default if invoice or transactions exist for the contact.

3. Fixed an issue with taxes being applied correctly to expenses being invoiced with markup.
4. Fixed the expense cost calculation on the Slip with Cost report. Cost for expense is now the Total for the expense 

slip. This change was made to all other time/expense reports that use the same data.
5. Fixed an issue to force "no charge" slips to be $0 on slip reports. Affects most time/expense reports using the 

same type of data.
6. Updated Invoiced values in the invoice table to correct for expenses and markups. Wrote SQL to correct for prior 

data problems. Now when looking at Invoice>Detail view, all fields should have $0 at least (not null), and the 
values should add up to the total invoiced amount.

7. Fixed an issue in the converter were project tax rates needed to be /100 when loaded from v8.
8. Prepared SQL code to sweep the project_bill table and correct all tax rates that were loaded incorrectly (change 

1750% to 17.5%).
v73

1. Investigated issue involving the billing checkbox on the Contact>Detail screen; was unable to find a problem. Can 
someone confirm it is working okay in v73?

2. Removed buttons from licensing wizard screens; only licensing is to be done at this screen.
3. Tax rates now support two decimal places (7.25%).
4. Investigated issue involving the conversion of doc templates to rtf on the Mac. Word for Mac does not have the 

necessary libraries; process must be done on PC.
5. Time/Exp card views now show International date format, if that is selected in Preferences.
6. Reports can now "use current found set", using the records on the corressponding source tables list view.
7. Prepared a set of International date formatted invoice templates for testing by support.
8. Project/RFP numbers can now use "-", " ", or "." as the number separator (like 2010-0010, 2010 0010, 

2010.0010). Updated onscreen help to reflect the change.
9. Company name will now appear on Invoices.
10. Department field in Project>Details layout has now been added to the Project Find layout and can be used in 

searches.
11. Invoices can no longer be created for RFP projects.
12. Editing Preferences>Phases/Job Codes/Tasks with children is restricted to only those fields not rolled-up from 

children. When added to projects, the parents/children are added with correct values.
13. Project>Slips layout filters now only show the date and not datetime.
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14. Project>Slips layout now refreshes correctly when navigating through projects in the foundset.
15. Update Job Code menu in Time/Exp>List view now refreshes the list view.
16. Update Phase menu in Time/Exp>List view now checks to see if the slips existing Job Code is active for the 

Phase, and clears it only if it is not available.
17. Navigating from Time/Exp>List view to the Time/Exp>Detail view now reflects the same record and sort order.
18. No charge checkbox is now defaulting on in the TimeCard view, after updating an existing record.
19. Implemented the ability to Bill/Unbill a single time slip from the Time/Exp>Detail view. Now uses the same Invoice 

selection menu format as Update Bill menu option in Time/Exp>List view.
20. Updating Phase and Job Code menu option in Time/Exp>List view is now functioning correctly.
21. Changing Slips to status "Billed" now is reflected properly in Time/Exp>List view, Time/Exp>Detail view and 

Project>Slips view.
22. Slip Report with Cost should now be calculating the cost of Time slips correctly (Hrs * CostRate).
23. Fixed issue with Milestones from Preferences not loading in the correct order.

v72
1. Fixed an issue with by restoring two invoice templates into the system (Type A and Type B)

v71
1. Made some additional changes to project calcs
2. Needed to force all project calcs to refresh to apply project calc changes

v70
1. Fixed issue when attempting to navigate to Calendar>Detail view and no events had been created yet.Now the 

user cannot get to the Detail view unless an event exists that they are allowed to view.
2. Fixed issue where Project>Billing>Options view was not refreshing properly for a newly created project.
3. Fixed issue with Preferences>Project>Tasks Tasks with children cannot have a budget or responsible user.
4. Fixed converter issue where calendar events were not being loaded properly.

v69
1. Fixed and issue with list views that threw a Java error when custom user sort orders were in use
2. Modified phase calculations for previously invoiced fixed, hourly and project invoiced fixed, hourly totals, to 

accommodate users that migrated over from QuickBooks.
3. Updated HELP menu to show "Online Manual"
4. Updated Converter messages to display AO2010 and the export requirement of 8.9.6+.
5. Modified converter's post conversion invoice calculations to compute the remit date from the invoice date and 

terms (missing in some users v8 files).
6. Modified licensing algorithm to accommodate numbers in the company name. Now supports the following 

characters: "abcdefghijklmnopqrstuvwxyz ,-+.&0123456789"
v68

1. In Preferences>Projects>Tasks added fields comments, hours and responsible users. These are also copied to 
new projects when created.

2. In Preferences>Users>Time/Exp added user preference for Project value list format in the Time module. Now 
project number, name, number:name and name:number can be used for slip entry.

3. In Preferences>System>Backup added support for daily or hourly backup job scheduling.
4. Added the ability to "Use Current Foundset" for reports. You have the option now of doing a search and using the 

foundset, or simply using the foundset for the list view that the report table is based on.
5. When viewing the Tiime/Exp>Filter layout, the NEW button is removed, as it is not relevant in this view.
6. If no Adjustment Description is specified for an invoice with an adjustment, null is no longer displayed.
7. Fixed invoice calculation issue with hourly cap used with DSE/DPE billing.
8. Fixed errors encountered while creating a new or duplicating project from the Project>Billing>Options layout. Now 

goes to the Project>Details layout first.
9. Fixed issue to restore menus for the appropriate module, when going to do a find, canceling, and returning to the 

module you were in.
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